New software update Kola Nut 1.8.5 is ready

I just wanted to give feedback that the update ran smoothly on my phone. I had to do two updates, though, one “pre-update” and the actual update after that. I was on 1.8 before.

Except re-arranging the icons and widgets, I had to do nothing, all settings, messages, media, mails etc. were present. I did not have to use my backup. (Which is strictly recommended, better safe than sorry.)

Now the old launcher is back. I did not make up my mind yet if I keep it. I already got used the new launcher on 1.8 and it was advanced in some respects.

1 Like

I just started the update to 1.8.5. Accidentally I hit the “Just Once” button when allowing Superuser rights.

Now the phone rebootet for the first time but:

“Unfortunately, Fairphone Updater has stopped.” --> So I can’t invoke that anymore.
+
“Get Google Play services” --> I don’t have Google Play Service either. Ahhhhh! >.<

SRLY? My phone turned into a brick?

What can I do?

You can go to Settings > Superuser and give the Updater permanent Superuser rights there. Maybe if you reboot afterwards the update will continue or starting the process again will work…

Thank you for the reply. I do have “Fairphone OS” in the list at Settings/Superuser but not the “Fairphone Updater” which breaks. Maybe it sounds dumb, but can you give a me link on how to add apps to this list if they are not present?

Sorry I didn’t find that option either.
Another thing you could try is clear the cache and data of the Updater App. (Settings > Apps > All > Fairphone Updater > “clear cache” & “clear data”)
Maybe then you can start it again. You’ll probably have to start the update from the beginning again. This time give it permanent superuser access :wink:

Besides the problem, that Google Play Services says, GCM is disabled ( after trying all kind of tricks like written here: Help with Xprivacy settings relating to Google Apps ),
I can’t play music tracks as ringtones anymore. music is still there (SD) but stopped working as a ringtone …
In your list of details of general improvements of 1.8.5 you wrote:

Users who have already installed the storage upgrade (with a unified
partition) reported it was no longer possible to use a song stored on
the SD card as a ringtone. This issue has been fixed;

I didn’t install the storage upgrade but use the final Kola Nut version. Any Idea?

I have FP1 and the drive partition.
I have installed the update but cannot reinstall Google apps as I get the error:
'no more room on this home screen’
The phone only has one Home screen and can’t create any more.

I have also tried to install the KitKat launcher as per the link above but it won’t install as the phone says teh Install is Blocked as for security the phone blocks apps from unknown sources. Then I unblocked and tried to install the update but it said it was already installed

help please!

Thaank you

I have two screens on the left of the homescreen.
so you must place google apps on an screen, which is not full with apps.

@MikeGrenville
Open the Updater App again.
If it tells you that you are on 1.8 install 1.8.5. (I believe you only did the pre-update yet, because in 1.8.5 you have a fixed number of 5 home screens)
After the update you can open the updater app again and install google apps from within it.

@paulakreuzer: No, didn’t help. Now, I made a factory reset via BIOS (holding volume up and power during boot). Ok, all my apps and settings are gone, but I have Google apps again …

Fairphone Updater still crashing. I have to reinstall all my stuff again (thx, I made a backup before).

But, seriously, this update is screwed. I’m very disappointed.

Hello @jopi79,

Given you “played” with modifying the partition layout you might be aware of the dangers here. We have carefully rearranged the partition layout of the “1G13G” builds and the unified partition to ensure that the system partition (containing most of the code) does not change location and size. This allowed for a 2 step re-partitioning where the first step is similar to a normal update (and the system partition gets written first). The second step of the process is the partitioning after an initial reboot.

We can not support people who changed their partition because of the above process(it requires a certain partition layout to start with). If you have ideas how we can help you we can try.

Changing the partitions like this is challenging but it allows us to provide a OTA partition upgrader. The current problem we have with the partition upgrader is caused by plain lack of testing(We tested the upgrader but did not test gapps installation after that).

1 Like

@keesj For people who ‘played’ with their partitions and are stuck now or in the future: if you use the unbrick/flash route you will reset your partitions layout to the FP1U compatible layout, which should mean less problems in future updates.

On a side-note: Are people who use Unified able to see their internal storage when connected normally to a pc? Or external SD only? Or is this just a quirk for people like mee who have a FP1 original and used Meteos and flashed to FP1U?

1 Like

If you did the unified partition the content will no longer be exposed over “mass storage”. However it will get exposed as MTP devices and depending on you OS you might not even notice the difference. Perhaps a forum search will help here!

@daveboschma & @keesj I would just like to remind: I and others have not played around with partitions and still we’re stuck as we’re unable to flash any OS after installing only Storage Upgrader manually according to official fairphone manual install site coming from 1.6 old partition layout. I hope that this can be fixed otherwise we’re quite lost although we have tried to follow as close as documented the official Fairphone install recommendations.

Kees, the issue here is that the Recovery Console does not see the /sdcard storage any more and therefore cannot install any OS (or whatever) sent to both internal or external storage.

@Amber I am painfully aware that you followed the official route and still got stuck.

@keesj Thanks for you’re quick reply, will try the MTP-mode in future.

Hello Amber,

We have identified the problem(recovery not being flashed) and fixed it on a soon to be released partition upgrader. We are now working on a fix for the current users who already did the upgrade.

3 Likes

Thankfully the Updater App came back - this time it all went through fine and it updated along with Google apps.

Thank you

2 Likes

Hi all,

Our software team fixed the issue and the Storage Upgrader 1.8.5 is back online - through the Fairphone Updater app and as a manual download.

For the users that are affected by the issue introduced in the previous Storage Upgrader; we are still working on solution for you.

Cheers,

Rick

1 Like

@daveboschma , when I connect the FP to my pc, I also only see my external SD-card and not internal storage anymore. I did before I ran the manual storage updater.
On the phone itself I see both.