New software update Kola Nut 1.8.5 is ready

Had the same problem - @paulakreuzer s answer helped!
Thaks :slight_smile:

1 Like


Currently the google apps are installing on my phone again…
hope it is going to work

1 Like

Yes you should do a thorough backup first as everything will be wiped. But the unified storage will keep you from having these problems in the future and whether you do it in 1.6 or 1.8.5 everything will be wiped anyway. Also a good backup should be done before any software update.

Thank you very much for your answears!
Currently I have not enough time to do this and I think it’s to complicate for me. My phone should just work, so no update for me. But thanks!

Is your Wifi symbol grey? This would indicate that there is no connection to the Google servers.

To all who have used a custom partitioner in the past (before Unified came into existence). Follow the post of jopi79.
I ran out of time this morning so I am continuing now. The problem for people who converted to a 4GB/8GB setup is that in the proces the cache partition (/cache) was resized to a very small 123MB. Obviously 201MB doesn’t fit into 123MB so you’re stuck!

BEWARE using manual flashing will get you in the google apps updater loop! See Google Apps can't be reinstalled for more details.

Only work-around this evening is going the extra mile and FLASH a recovery image of 1.6 using the SP Flash method. If you are not comfortable with flashing an image to your phone, wait for the official new installer tomorrow!

Manual update procedure (different from flashing, see other post!)

  • Make a backup (DONT SKIP THE BACKUP, you will wipe your phone in the process, so everything not backed up or on SD is lost)
  • Download the manual update. (preferably the “storage 1.8.5”, since manual updating overwrites everything, so you might as well go for Unified)
  • save to phones INTERNAL SD (in the downloads folder), the external SD (eg the card you can insert) is not accesable in recovery because e3 recovery will only see the internal SD. After this hole proces you’ve got Unified so recovery sees your external SD as the only one.
  • boot into recovery
  • install manually
  • wipe cache
  • wipe data
  • reboot
  • reinstall g-apps
  • recover files from backup
  • reinstall apps as needed

Does this bring your keyboard back?

(Alternatively, if you don’t want to install Google Apps, you can go to Settings > Language & Input and choose the AOSP keyboard.)

See posts of jopi79 and myself (message 118). Manual update required if you repartitioned using Meteos or similar)

@anon12454812 @Techaddict
Can you please mention in the topic starter message that the pre-update (step 1) kills g-apps…

yep, this would be an important info BEFORE starting the update

Could you elaborate a little bit on this? If I install the new Fairphone updater app (pre-update) on a 1.6/1.8 phone it doesn’t remove/kill my app store.

The pre-update step kills g-apps completely on a 1.8 phone. After the reboot g-apps is gone. When updating to 1.8.5 gapps gets reinstalled.

This is the root cause of all people having (in 1.8 before update, after pre-update step):

  • a grey wifi symbol
  • messages complaining about apps that require gapps sing-in
  • play store missing

I did the PreUpdate, now the updater app doesn’t start anymore. Restart the phone and clearing cache and data from the updater app as paulakreuzer mentioned above doesn’t change anything.

What should i do now?

Instead of having my only free evening this week with my family i have to work out the problems you did with this buggy update. Thanks for wasting my precious time…

For with the same issue:

I installed the version Storage Upgrade 1.8.5 manually.
No I have at least the latest version.

Nonetheless, GApps is not installing properly.
The support guys said the GApps is to blame and they are going to work it out tomorrow…

…so no solution tonight

@Flavio_Ranica - it’s hard to track replies in here but I don’t think anyone has responded to you.

You could try the guide here How to restore Fairphone if you totally bricked it

You might be able to connect with the SP Flash Tool and reinstall using the binaries. You should be able to use this binary file which will bring you up to v1.8.5 in one install


I tried to install the storage upgrader via the recovery mode, but installation fails (even after wipe).

I thought I’d follow your procedure… I’m all set, connected to my phone with an adb shell, but…

there’s no “fs_upgrade.bin” in the /system/bin/ folder of the storage upgrader.

do I have the right file?

where do I go from here?

a list of commands I can input into the ADB shell would be great

@gsoundsgood Did you try a sideload of the 1.8.5 zip? or are you in adb shell?

Please note that upgrading manually will get you in the gapps install loop. If you do not need to upgrade tonight consider waiting for tomorrow.

1 Like

I keep getting “updater has stopped”. I tried deleting the updater’s cache, then I tried deleting its data.
Last thing I tried was factory reset, but the problem persists even with that.

1 Like

Wow. Update, complains, months of software development, betsa testing group, and still lots of problems. But I guess that is very hard to avoid when FP owners have root access, custom partitioning, update from different software versions, etc.

Good luck making the next updates more foolproof. I do hope all who post on this thread are the only ones having issues :slight_smile:


Don’t go into adb shell, but try the following:

On your phone: Enter recovery mode and choose “sideload”. Connect via USB.
On your computer: Issue adb sideload

The process of updating should start.