New FP3: Your device is corrupt

Today arrived my new FP3, I have been configuring the date, I changed the AM/PM to 24H, the device reset and then I get this image:

Your device is corrupt. It can’t be trusted and may not work properly. Visit this link on another device:

If power key is not pressed: Your device will poweroff in 30 seconds.

Sometimes works for a while, but ends reseting, i have a video too:

some help?

1 Like

The site is a google site.
When visiting the site, that is displayed in the picture, you get this text:

Understand warning about operating system safety

When you turn on an Android device, it checks the operating system to make sure it’s safe to use. This means the code comes from a trusted source and hasn’t been changed or corrupted.

If your operating system could have a problem, you can get a warning message that brings you to this page ( ).

If you changed the operating system on purpose

You can continue using your device. But you acknowledge that your device might not work properly and your data could be exposed to corruption and security risks.

We recommend restoring your device’s operating system. If you have a Pixel or Nexus, learn how to flash your device with the latest factory image.

If you didn’t change the operating system yourself

Therefore it looks, like the trouble is with your Android OS.
You should definitely inform support, as it seems, the OS installed on your device is corrupt, if you really didn’t do more than you described. And this could affect other users as well.

But you can of course “reset your device” and Install Fairphone OS on Fairphone 3 using a Computer


The 30 second message can be turned off (see below), but it is a sign something went wrong with an OS install or partition restore or something along those lines.
Was it already there before you tried to reinstall the OS, or was it a result of trying to reinstall the OS?

If trying to reinstall the OS caused the 30 second message, then I would suggest trying again, but this time making sure to not use adb and fastboot from your Linux distribution like the guide suggests, but from the current Android SDK Platform Tools.
(Or use a Windows computer. I don’t know whether it’s still the case right now, but there were bad fastboot versions around in Linux a while ago, causing trouble.)

If the OS installs successfully and still reboots randomly, it’s a support case …

Or you could return the phone within the cool-off period.

… works once Android or TWRP are booted.


Thank you guys, I solved it flashing through windows and removing the 30 seconds advice enabling debug mode:
1.- Enable developer options: System -> about phone > build number (tap ten times)
2.- Enable USB Debug mode: System -> Advanced -> developer options -> USB debugging -> ON

Then you can plug the phone into PC and:

adb reboot "dm-verity enforcing"


Great to hear, but the question remains why you experienced this issue on a new FP3. Have you reported it to the official Fairphone support? This would probably be a good idea.

Best wishes,


I reported it before i writed this post, and get response… today, anyway it’s solved

OK, but for a brand new device, your issue really is quite suspicious. I hope you will not experience it again.


has happened again…

adb reboot "dm-verity enforcing" again and it works fine, but the phone has an error, i reopened the issue with fairphone.

when happened the phone didn’t detect the SIM, then changed to slot 2 and “works fine”…

What was their prior response?

zital July 17, 2020 10:17

Yesterday arrived the FP3, I was changing the clock format and the phone reset. Then I have a message "

Your device is corrupt. It can’t be trusted and may not work properly. Visit this link on another device: Understand warning about operating system safety - Android Help 1

If power key is not pressed: Your device will poweroff in 30 seconds.

bb152d22e6a43bdd.jpg (200 KB)
2821f6af98b390a5.mp4 (7 MB)

“Support” July 21, 2020 09:24
Dear zital,

Thank you for contacting us and flagging this issue. My name is “Support” from the Fairphone support team and I’ll be your case manager, nice to meet you. I am sincerely sorry for this inconvenience.

In order to help you further, we kindly ask you to provide us the following information:

Which steps did you perform before the issue occurred?
Have you ever unlocked the bootloader of your Fairphone 3? If yes, has the issue occurred before or after you locked it again?
Have you installed a custom rom? If yes, which one? By examining the different OS (Operative System) you tried to install on your Fairphone 3, our technicians might be able to provide a quick solution for you and the other customers in the same situation.
When you see the error message, please, click once on the power button within 30 seconds, your device should boot and work as usual. If you wait more than 30 seconds, your device will power off.
In this case you can simply power it on and try again.
    If this does not happen as I described, please send us a video: we need to check what happens with your device before we send it to our technicians. 

In the meantime, I will forward your request to our technical department who is cooperating with our engineers to verify what happened and to work on a possible long term solution.

In the next future, they might come back either to have more information or to request access to your device.

In the meantime, if the issue occurs again, please just click the power button once you see that screen. Your device should work as usual.

Thank you in advance for your cooperation.

Have a nice day!

Best regards,

“Support” - Technical Support Officer
Italiano - English

☆ Fairphone || Buy a phone, join a movement!

✆ EN, DE & FR +31 20 788 4400
Monday to Friday, 10:00-17:00 CET

zital July 21, 2020 11:29

I don’t install anything, I power up the phone and at first 5 min occurred the issue. If you watch de video, pulsing the power button reset the phone to show another time the error for infinite. Sometimes booted, but not usually. Anyway, I solved the issue:

But is a bad way to start with Fairphone, I can flash and hack… but I have no desire to do this things, It’s very frustrating, I have problems installing drivers etc…

this video show perfectly how I feel fixing the ************* fairphone


“Support” Thursday at 15:27

Dear zital,

Thank you for your message and the interesting video you shared. I am glad to hear you already found a solution.
Indeed it is not something that normally should happen when you buy a new phone. It is an error message usually related to flashing process being interrupted or device being unlocked to install a different OS.

Now that I know all is well, I will close this ticket, but if you need our support in the future, you can always reach out to us creating a new request on our support website. I will be happy to help you again!

I wish you a great day!

Best regards,

“Support” - Technical Support Officer
Italiano - English

☆ Fairphone || Buy a phone, join a movement!

✆ EN, DE & FR +31 20 788 4400
Monday to Friday, 10:00-17:00 CET

zital Today at 08:09

Same issue again, the phone power off by surprise. Power on, and the same issue as the first post. Power on, push power button to launch android, but reset the phone, too many times. Finally loaded android but the SIM not recognized, remove battery and start again… changed the SIM slot… I don’t know what is the problem, but the phone is randomly crazy


I really feel for you!!!
Sounds like a warranty-case to me.
As bad as it is, but I would not trust this device any more and would send it in.
Tinkering around/tampering with the phone any more might in the end cause more trouble than it’s worth.
I would expect Fairphone to ask you to send in the phone, but one never knows.


Sounds like hardware trouble to me, hopefully they will not make much fuss and exchange the phone.


thank you guys, I’m waiting the support response, but I think I would have to send the phone to repair.


The support teams send me the instructions to send to repair, thanks for your support guys :slight_smile:


software reset and cleaning… well I think the issue is due to the SIM date & time synchronization, I changed to manual time and SIM GMT hour change. Pray for Mojo…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.