New display stays black while FP2 starts


Today i have been installing a new display, battery and bottom module while waiting 3 Months for it - and it still doesn’t work… The Phone seems to be working (because of the LED and the vibrations when i start it), but the screen stays black. I tried different things, for example to install a newer softwareversion manually, but it didn’d help… So i really hope to find some help here, while slowly losing patience…

Can anybody help me here?

Are you running the latest OS version?
As far as I recall, the new displays require FP (O)OS 17.10.x

If that’s the case, you might be looking for a FP-Angel in your area, for helping you with testing your display or maybe swapping displays so you can update.
You can locate the nearest angel on the #communitymap.

1 Like

@BertG is right, the OS version has to be new enough.

Does the recovery work perhaps (hold Volume Up pressed when starting/rebooting the phone)?

Since you seem to know your way around doing things manually, you could try booting the latest TWRP recovery version without flashing it … it supports the new displays, so something should show up on the display if it is not a hardware problem.


Hey BertG

Thanks for your Help!
I couldn’t find an FP-Angel in my Area. And yes i tried to install the latest OS version the day i posted here, but it didn’d work. I’ll try it again.

1 Like

Hello anotherElk

Thanks for your Help!
The recovery doesn’t work.
No i don’t really know how to do things manually, i found an introduction and tried it then, was surprised that i made it my own haha :wink:
So i’ll try booting the latest TWRP recovery version without flashing it - next level haha let’s go :wink: Thank you!


I wonder: Did installing a new OS not work or did it not solve your issue?

Did you do it according to this guide:

Yes I did it according to that guide.
The first Time on the “manual flashing script” was written, that no Phone could be found.
And as I tried it again yesterday, there was written: “checksums do not match, try to download the manual update again.” - i did that several times, but it was always the same error.
I’m gonna try it on another computer later… Or do you maybe have an Idea?

Okay, so i tried it on another Computer and there’s written the same Message as when I tried it the very first time:

** Fairphone OS 17.22.2 Manual Flashing Script**
Validating files…
All files are valid, let’s go!

WARNING: No device found in fastboot mode
WARNING: Make sure that a fairphone 2 is connected
WARNING: To check for devices, type 'bin…
Do you want to try it again?..Yes/No

It sounds to me as if the fastboot driver on your computer does not work.
Which is your operating system? Which driver do you use?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.