New Camera+ and Top+ Module on my FP3: GPS broken


I bought myself the new Camera+ and Top+ Module and placed it into my FP3. All fine.
Until I realized that my GPS is now going frenzy: for a running streak which is about 5,4 km it now reports 14,0 km, having an ascend of 2km and descend of 2km and a max speed of over 60 km/h in half an hour… on foot!!!

Anyone experiencing simliar? Does anyone have a remedy?

There is a GPS test in the Service tests. Launch the phone app and dial * # * # 6 6 # * # * (omit the gaps) to get these tests:

Thx for the reply.

Well, the first test, the location, works as expected. My phone finds about 29 satellites and reports location rather immediately.
For the second test, I do not sense what to do. There are two numbers to be inserted and it escapes me why I should do that and what these numbers imply. Also, there ain’t any “Submit” or “Go” or “Run” button to actually launch this test.

What should I do?

For clarification: my problem is not that GPS is not working, rather than the GPS location on phone is jumping around like mad as if it had way too many espressos in way too little time. From the perspective of a tracking app it’s like teleporting some meters around in seconds. This covers a lot of distance in no time…

I’ve installed the latest FP OS update offered to me on the weekend (Build 8901.3.A.0066.20201119) and installed a second runner tracking app. Today I got good result while having both tracking apps active during my workout.

So maybe this bug has been fixed by either the OS update and unnoticed update by my primary running app or when having both tracker active. I’ll continue with these experiments and while post here my findings.

1 Like

Meeh, it’s me again. The GPS woes started to reoccur. I’ve worked now with a second runner app and the same thing: while running the GPS jumps around like mad resulting in a running distance which is sometimes 25 % (!!) exaggerated. Tried different things like reboot, etc.

Is there some log of the GPS I can turn on, create, download and examine! This is really a serious bug for me, crippling my Fairphone experience immense (I’m running ca. 80km a month).

I have a similar problem. When I run the distance is incorrect and the figure showing where I ran too. I also always get a notification that my GPS signal is weak. Let’s hope we can find a solution.

Thank you Sascha for commenting on this.

My particular problem is, that when I check the track in my running app, it seems that I’m running like zigzag. The GPS Positions are jumping wild, while in reality I just run a straight line. Yet this zigzag is causing the running app to calculate way too much kilometers. It’s hard to put a good number on this, but I’d estimate it is really up to 25% off, which renders my running stats pretty useless. Though very, very impressive!! I have admit that =)

Is this your problem?

Yes, sometimes it is very impressive while last Monday it was embarrassing as it logged only half my run…
I recognize the zigzagging! But for me, it is that or no signal at all interchangeably.

Do you also experience trouble with navigation? If I use google maps, it gives me completely useless instructions because it never knows where I am.

I am thinking, maybe we could replace a module that would fix this problem?

Hmm, I do get always a GPS signal. So I’m never without.

Though I have to admit, that sometimes in my running app I run a few meters in the lake nearby.

I’m still not sure if it is the hardware module, the operating system, the driver or even my running app. Most likely the latter not, but I would appreciate if someone could tell me way to log the raw GPS events to verify and somehow get to the root of this problem.

BTW: I have a FP3 which I upgraded with new module. It is still running the recommended FairPhone OS (with the most recent update and fixed applied).

Updated to the latest OS today and just returned from a run. GPS still jumping around, though a little bit better. But just one single sample as of now. =(

/me == sad -.-

I’m wondering if another ROM may solve this issue? Maybe LineageOS?

Just turned off and deactivated everything looking like Energy Savings and installed “GPS Connected” app to keep my GPS on.

Still same problems. GPS signals jump around like mad. Inspecting my running route in the app reveals places and streaks I’ve never been. The signal is sometimes 50m (!) off like across a river.

This is unusable! HELP!

This is getting somehow really funny. Today my FP3 reported, I run 35,76 km in 1:44:08.
My FP3-GPS is getting worse by the minute.

Just to say because I see no mention of it: Have you contacted support yet? …

Thx. Yes, I did.
Months ago. Then it seemed somehow fixed (as of January).
But recently I opened up a follow-up.
Original Bug report:
Follow Up Bug report:

No response on the follow-up yet.

1 Like

For the records: Fairphone has reacted to my problems and recommends to do a factory reset, which I currently still refrain.

In the meanwhile I bought myself a Garmin Forerunner 45 and verified my standard running track against my last 6 runs with the FP3. Examining the results of the Garmin GPS watch seem very, very accurate to me. Some few points diverge by a maximum of roughly 5 metres but in average the measurement is very, very close to the real track on map. The measurements by the FP3 of the last 6 runs compared to this one Garmin is off by an average of +28%.

You have been struggling with the issue for more than five months. Should you still have the old modules, I suggest to use these for a while and check whether the issue is gone or not. And when it is gone, you can report your experience to Fairphone and request further instructions on how to deal with the issue…

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.