Netflix on CalyxOS with Fairphone 4

Thank you very much for your reply. Well, if I try to open the app from aurora store, it loads the netflix logo and thats it. After a while Ill get an error message. I tried different browsers as well, but with the same result as you: error messages.
May I ask you what settings youre using? I have microg activated, device profile automatic and google safety net deactivated. I tried multiple settings (I guess every variation) but nothing helps. I would love to have the app working, so that I can download movies.

Might this cause the problem?


For me, that does not seem to be the case, as Google Safteynet is deactivated on my device, too (in all profiles), and the Netflix app is working fine.

I do not remember though whether I had it activated on first use of the app or not, so maybe it was worth a try to activate it and reinstall, if not already tried, to see if something changes.

Apart from that, I have microg activated and allowd notifications for Netflix.

One other remark: I run the app in the work profile to isolate it a bit more from personal data (and freeze it using shelter if need be, not trusting this kind of software), but no idea whether that has any impact.

Hey Volker
Unfortunately, it doesnt make a difference wheter I turn it on or off. I tried both ways…

1 Like

Hey cosmic
Thats really strange. I tried it like you recommended; I reinstalled the app with microg activated / deactivated. Also, I tried to install it in the work profile… but no success so far…

The problem seems to be related to the status of your bootloader.

Since I also was affected, I tried everything I could.

Latest Stock with and without root
Latest CalyxOS with and without root
Latest LineageOS with and without root
Latest LineageOS MicroG with and without root
Latest /e/OS with and without root.

Neither Netflix nor Disney+ worked, Prime Video did though.

Finally I locked my bootloader and all of a sudden it worked.

So to me the question now is, how to hide the unlocked bootloader with Magisk 24+. Is there any way? I know how to do it with Magisk 23 and lower.

Other problems with my new Fairphone 4:

  1. Is there a chance for an adblocker under latest /e/OS with locked bootloader and therefore without root? Or at least to change the hostfile?

  2. Has anyone manages to shoot photos with a resolution higher than 12MP? The vendors specs read 48MP. What do I do wrong?

  3. Any way to sync my old OnePlus 7T Pro (with root) with my new FP4 without using Google?


Did you try blokada? It’ll use the vpn function. So you won’t be able to use advanced privacy VPN at the same time, but do you use it at all?

1 Like

try NexdDNS:

1 Like

Hi Volker,

Thank you for your answer!

I have not tried it yet, since I’ve never heard of it before. I will definately give it a shot. In the /e/OS-App Lounge I can find Blokada 5 and 6. Which one do you recommend?

I will also try that. Thank you, too!

Currently I don’t use it (PiHole is sufficient for me). But according to what I read I’d give Blokada 5 a try (don’t like those “super-cool modern cloud based services” too much…).

1 Like

Yes, PiHole is running here, too. But unfortunately only suitable, when at home :grinning:

1 Like

my bootloader is locked but the netlfix app still doesn’t launch.
any further ideas?

Reinstalling the whole app might help, because your old bootloader status might be saved within the data.

If that doesn’t help, then unfortunately I have no other idea.

Personally I would consider rooting with Magisk v23 at the highest and hide it from Netflix and others.

I was surprised to read that and tested it in my iodeOS.
Also degoogled ROM with microG and aurora store.

1 Like

What about your bootloader? Is it locked? If not, I might try it myself.

It is locked
But i can try it with unlocked too

Im kinda cursed: Netflix doesnt work with iodé os as much as it didnt with calyxos. Not a big deal (for me), but im not gonna lie that I would like to run it tho. Whats the damn problem with my phone - lol

As mentioned, for me none of the OSs worked with Netflix until I relocked my bootloader.

My bootloader is locked too :confused: