English

Netflix not installable on FP3?

I solved it by installing an older version of the app. In three steps:

  1. Download older version of Netflix apk-file. I got mine by searching for Netflix on apkmirror.com. Had to do some scrolling and pressing buttons to find this file:
    https://www.apkmirror.com/apk/netflix-inc/netflix/netflix-6-25-0-build-10-31666-release/#downloads
  2. Install the app “APK installer” from Google Play
  3. Start APK installer app, press Install APK button, check Netflix checkbox, press Install button.

Latest Update for FP3 fixed the SafeteyNet issue, so Netflix can be installed via Play Store again

4 Likes

I still can’t install, or even find the Netflix app, via the play store. When I search for the app via Google Chrome on the web version of the play store, I can find the app, but there is a notification stating my device is not compatible with this version (Je apparaat is niet compatibel met deze versie).

As far as I know my device is updated to the latest version. When I go to settings - system - advanced - systems updates, it says my phone is up to date. Should I update something else?

There is a problem with updates that seems to happen only for people who have a contract with Vodafone or Orange: Has anybody received the latest security update yet?

In this case the updater would show that the phone is up to date when in fact it isn’t.

In the version info for your phone it should show A.0118 and a security patch level of 2020-04-05 if you are really on the most recent version.

1 Like

My security patch level is 5th of February 2020. In the “About phone” section it says I’m on build 8901.2.A.0111.20200131-userdebug. Can I update it manually? My contract is with Dutch provider Tele2 but I’m not sure how that could be related. I bought the phone straight from Fairphone.

With this build you shouldn’t have the SafetyNet issue, it was fixed with A.0111 (it’s the “Fix for Google Pay issue”).

Does the Play Store App display something different when you search there?

I can’t find the Netflix app at all in the play store app :confused:

As @Ingo already wrote further above

In the version info for your phone it should show A.0118 and a security patch level of 2020-04-05 if you are really on the most recent version.

So please try to update to A.0118 first, which you should do anyway because it contains some important security patches. If you have a Vodafone SIM (or one from a provider that uses Vodafones network) try another SIM temporarily to receive the OTA.

Good luck!

1 Like

I am not on the Vodafone network. Just to be sure I finally got around to trying another SIM, which is on the KPN network. Still wasn’t able to receive the last system update, so I’m stuck on A.0111.

Does anybody have any other solutions or things I could try? Otherwise I guess I’ll contact the Fairphone service desk.

Just a quick update. So I contacted support, and it seems my phone has been flashed to the wrong version (a debug version) of Android when I had to send it in a couple of weeks back. That’s why it won’t update, and that’s why Netflix isn’t working (probably).

2 Likes

Hi

Bought a new fair phone 3 through Vodafone and neither netflix or disney+ are available on google play store. Very disappointed. is there anyway to overcome this issue? If not I’m afraid I will have to return my fairphone :frowning_face:

All help appreciated

Hi Graham and welcome to the Fairphone community forum!

I moved your question here as it’s the same underlying problem.

You should contact Fairphone support about it as the community cannot solve the problem.

If you scroll through this topic a bit you might find a workaround, though: installing an older version of the app(s).

Hasn’t this been fixed with an update recently?

@grahamfinnerty Try Settings > System > Advanced > System Update to check if there is an OS update for your FP3.

Hi

Thanks for getting back to me

I only turned on the phone for the first time yesterday. It was brand new. Should it need an update already?

Yes, most likely. Any smartphone manufacturer will not keep opening packed smartphones in a warehouse every few weeks to update the software. The phones come with the most recent software that was available when they left the factory.

2 Likes

I checked for updates and the phone is up to date. Still no Netflix on Google play store. Anything else I can do

Just to be sure … What does it say in Settings - About phone - Build number?

2 Likes

That’s unfortunately not the most recent OS version (the last line should include an “A.0124” or “A.0134” string, not just “A.0110”). As you are on Vodafone, you might be affected by an update blockage which leaves you with two ways to still update to the most recent (A.0124 or A.0134) version:

  • If you have a second SIM that is not using the Vodafone net, replace the Vodafone card by it temporarily and try to update again as described before.
  • If you only have the Vodafone SIM, you can try to update by connecting the FP3 to a computer and following these instructions:
2 Likes