Need to reflash but cannot enable it from Settings because a bootloop doesn't let me get that far

My FP4 is insisting on a factory reset, but crashes partway through it. I’m trying to get past that by reflashing it with the latest OS, but “fastboot flashing unlock” says it’s not allowed, presumably because I haven’t enabled it from Settings… which I can’t get into because of the bootloop.

(I think the whole thing may have been triggered by getting my first phone call or text after switching to an ESIM; it started soon after that, and also I get “” stopping, even within the bootloop.

Do you use Windows? If do there is a bug in the script…

German but should help

If I understand the problem correctly, the OP is stuck way before that.

Isn’t there an option to delete the eSIM as well during a factory reset in recovery (there is from a running system)? :thinking:
I don’t have a stock FP4 near me to check that at the moment …

Have you tried booting into Safe Mode?


Ok seems I should do some proper reading before posting, thanks for correcting

1 Like

I couldn’t see anything that seemed to be offering to delete the ESIM, nor a way to get into Safe Mode.

I have been to an EE shop and got them to cancel the ESIM, and when I tried booting after that it asked about downloading one, so I guess it had found that the old ESIM was no longer active.

And they provided a new physical SIM, which I have put into my previous phone and used it to call FP’s helpdesk, who have arranged to ship it back for servicing.



I was using a Debian Linux system (similar to Ubuntu). I don’t think it’s a bug in the script; the phone is (correctly) refusing to let fastboot reflash it, because I haven’t enabled that through the “Settings” app on the phone. The problem is that I can’t get to the settings app, because the phone crashes while booting, at some stage earlier than making apps available.

I’ve now spoken to Fairphone’s helpdesk and they’ve arranged for me to ship it back for “repair” which I presume means some kind of reset that I can’t do myself.

Thanks anyway,


1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.