English

Need help for an app not working on Open OS

Hey everyone !

My name is Ségolène, I’m French and I’m 27 years old.

I really need a very special app, that I can’t replace, and that won’t work on my phone. And I really like my google-free Open OS… It’s called Rankers NZ, it’s kind of the bible of camping sites around New Zealand, and it has no copycat or other app that could compete.
So I’ve tried the wiki Install every app on OpenOS. But I don’t really understand everything and it does not go the way the wiki says. So either I am doing something wrong or my phone is doing something wrong. I don’t know which, but either way, I really need some help !

So to get this app to work, I have tried everything as far as “Level 4: Tricking apps to work">“Hiding root with RootCloak”.

At that point, I tried to disable root, just in case, but it didn’t work, so I went on to try RootCloak. I installed Xposed downloader, went to the settings, chose sdk level 25, downloaded the newest entry, rebooted to recovery, and tried to install the downloaded file… which did not work. It gave me an error message (Zip signature verification failed - Error installing zip file ‘/sdcard/Download/xposed-v89-sdk25-arm.zip’), after a line saying “Skipping Digest check: no Digest file found”.

So here are stuff I don’t really understand and maybe made a mistake about :

  • considering Open OS has been upgraded since you wrote the wiki (not on Android 5.1 or 6.0 anymore), I chose sdk level 25 (the lattest) instead of 22 or 23 (it was actually pre-chosen)
  • I’m not sure what “reboot to recovery” means exactly, so I turned my phone of, and then while power on, I pressed volume up+power for 10 seconds; it took me to this weird mode that I don’t exactly know what it is, where I chose “Install” and then, went looking for the downloaded file; then I just ticked the “reboot after installed” box, and swiped to install.

Oh, and I read the few next steps, just in case, and it’s pretty much chinese to me…

So, after all this, can someone help me ? Has anybody had the same issue or does anybody understand what this means ? I’m kind of desperate because I really need that app. Please, help me !

Thank you for everything !

Be aware that tricking an App into working may break at any time.
If you really need the App to function reliably, you will have to give the App what it wants.

If the App wants to have Google services around, you may want to consult the “Alternative/Workaround 2: OpenGAPPS” section of the Wiki.

1 Like

Oh, okay, thank you ! Actually, I don’t know if it does not work because I don’t have Google services, but it is the only lead I have, so I’m trying it. Moreover considering it’s a map, so I wouldn’t be surprised if it worked on Google Map.

Are there other reasons for apps not to work on OpenOS ? I can I get to know why it’s not compatible ?

Thanks !

Yalp store says that this app depends from Google framework. And that’s very probable as the app is offered by Google Commerce Ltd.
So you should give opengapps a try as proposed by @AnotherElk.

… or try MicroG :slightly_smiling_face:

1 Like

“I really need” is a requirement which can’t reliably be met with microG.

Well, but in most cases it works, so I’d at least give it a try…

I see we have a different understanding of “I really need” :slight_smile: .

1 Like

I’m not so sure about that, it’s just that there probably is no urgent need to have the app, so I think it’s worth trying if MicroG works or not. If it’s a banking or healthcare app you totally need asap, then OpenGApps could be a better solution (not for me though).

Well thanks to all of you guys ! I found THE best solution : I needed another phone anyway for my international SIM card, and since my second SIM slot is broken, someone gavevme his spare cellphone. It works with Google Services, so I just put the app on it. But a real big thanks for your ideas !

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.