Need advise to restore or re-install FP Open OS with TWRP

Hi folks,

I have installed and played with Xposed for the first time of my geeky life, and unfortunately, I have done something wrong and I cannot download anything anymore.

I want to restore and re-install FP Open OS with TWRP, for that I have the FP Open OS 16.06 zip file on my SDcard.
So what is the simpliest or safiest or best way to do it ?
Is it as simple as using the install TWRP function ? Is there things to do or not to do ?
This will be my very first ROM flashing on my smartphone ! :stuck_out_tongue_closed_eyes:


I don’t think that you can easily install the OS from TWRP, as the zip files contains the recovery, which cannot be overwriten while using it. One way could be (though, I don’t know if it will work) to unzip the file and install the other images and leaving out the recovery image.

Anyhow, I think the easiest way to re-install FPOOS would be to use fastboot. You can find instructions for that here:

Install the image and leaving the recovery … it sounds like Chinese for me …
Unfortunatelly I cannot download anything … so fastboot is not possible !

Any other idea ? :sweat:

Which zip file do you have?

You can try to unzip this zip file on your computer, there should be different image files in the archive. The possibility I meant above would be to only install the system.img and the data.img file, this should be possible from TWRP. Though I never tried that and I don’t know if it ill work to re-install the FPOOS this way, but in theory it should work.
When being in TWRP, also wipe the cache first.

Though personally I would try the fastboot method. Maybe you can wait until you can download a new file.

You can go into the zip-file with Amaze and copy the image-files to another folder of your sd-card. If this is done, then reboot to recovery (PowerandVolume up together and hold and hold and …). There is a button “install image”, with that install all images but “recovery.img”.

I don’t know anything about your experiences with Xprivacy, but if you want to get rid of all that stuff made with Xprivacy then uninstall it.

Luckily I have the file. My problem is that I cannot access to the web because of my mistake nor downloading any app, which is why I n

Extracted files contain a recovery, a system and a META-INF folder and also a boot.img and a file_contexts files. What do you recommend ? Do I have to delete the recovery folder only and then Zip the files and folders again before to launch TWRP ? Or do I have to change or move something else ?


You could always download files on your computer and then transfer them to the phone, which is particularly easy if you have an sd card.

I’m not sure if re-install will work with the ota_from_gms, I would try the above mentioned method only with the userdebug file. Or, as I said, just use fastboot for a clean re-installation of the whole FPOOS. That seems to me as the cleanest & safest way, if your intention is to re-install the system.

Anyways, did you try uninstalling xposed?

Try it - do what I wrote. In recovery you are always one swipe away from execution, so you can have a look and if all is not like I told you, go back and rework it.

Unisntalling Xposed didn’t changed anything.

I’m trying the fastboot method, but when I launch the command line, I get this message .

I try to understand what is wrong, maybe my path for the file.
Anyway thank you for your insistence, you convinced me to use fastboot.

I got another idea : I found that for the ‘Fairphone OS 1.4.2’ I can use the OTA Switcher file, which means downloading the file on my computer, transfer it to my FP2 and then install it from the Updater, and then finally, switch back to FPOS.
But I’m still interested to know how to finalize the Fastboot method !

And the message is ?

What I do not understand: why don’t you try TWRP?


I think the message I get is < Waiting for device >.
The fact is that I’m a geek with some knowledge but I’m not an informatician, therefore I try to use the Fairphone files as it is, in the easiest/safiest way. The truth is that I’m scared to do something wrong and to be in a worst situation. TWRP seems to be too nerdy for me, but maybe, it is a wrong belief.

Anyway I appreciate your participation to help me to “repair” my FP2.

That it is, indeed …


Well, I will study your link to raise my fears and try TWRP when I’ll get some time.

TWRP has an intuitive GUI, just have a look it, pretty self-explanatory.
Anyhow, if you got fastboot to connect to your phone, following the guidelines on the manual install support page is also pretty straight forward.

As I said on the Fastboot topic, Fastboot does not “see” my FP2 (contrary to ADB), and as per your comment I understand that I could download the Gapps OS on my computer transfer it to my sd card and then launch the updater.

Finally I haven’t been at the end of the fastboot method … and still have to try the TWRP solution.

As I re-install FPOS once a month, you’ll probably heard about me soon …

Thanks guys !

OK, SOrry, I thought you could find your phone via fastboot. It should work though, if ADB finds it as well. Just keep in mind that the phone needs to be in fastboot mode (power + vol. down) in order that fastboot finds the phone. You may also need “sudo” on some Linux machines in front of fastboot commands.

But yes, there are plenty of possibilities to install/update the software; either by copying the file onto your sd card (then using the updater app or TWRP - for the different images) or directly from your computer (i.e. via fastboot). But note that you need different files for the different options. But you find that information & the according files here.

I have tried the “fastboot device” command but not “sudo fasboot devices”.
Just tried the “sudo fastboot devices” command in fastboot mode and FP2 is found. I also made a comment on the fastboot topic to confirm that.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.