My phone 'thinks' it's in a different time zone

I’ve updated the operating system but this problem persists.

I’m in London.

For the last month or so, my clock is 6 hours ahead, with a “home” time beneath it if I select the option for an additional home time while traveling.
However, if I go into settings, the time zone says LONDON- which is what it should be.

So, my phone seems to think I am somewhere else. I haven’t gone anywhere! :slight_smile:
But it also thinks I am where I am…

I can’t see where to disable “network selected time” as suggested in a similar post.
But as I said, it says I’m in London GMT anyway. It’s just not showing me that.

Pretty confused really. :confused:

Any help would be much appreciated! Thanks

To disable network selected time:

  • click on the screen clock. You should see three icons at the top and three at the bottom, e. g. the bottom-left one allows you to set an alarm.
  • click on the bottom-right icon, the one looking like a vertical “…” -these are the settings.
  • you then get a small local menu proposing you a ‘night mode’ and the settings: click on the latter
  • you should see the list of possible settings; the second one is the one you want, with an explanation below it. Uncheck that, and the phone won’t auto-adjust according to network time.

But, I wouldn’t do this.
Because, just below the previous setting, the next one says “my time zone”, and if you just click it, you’ll be able to announce your phone that indeed you are in London, GMT.
This, is I think the adjustment to do.
If I’m right you should then get back to GMT while still maintaining a permanently-corrected time.

Hi Herve5,

Thanks for your reply and excellent directions!

So, in my settings, I have these options:

Automatic home clock
Home time zone

Silence after
Snooze length

There is nothing there about network selected time.
Should there be?

I have tried :

•un-cheking the automatic home clock - this just hides/displays an
additional clock with the right time.

• changing the home time zone to various locations… makes no difference
at all, still 6 hours ahead!

So it seems as if my time zone is being set by some other option that I
can’t see.

Any thoughts?

Thanks very much

sorry for a very late reply: if you un-check the auto home clock, I think then you free yourself from the network. Then all that remains to do is correcting the time (by hand)