My FP4 doesn't support slots anymore . .

I’ve tried some different things on my FP4. MicroG, /e/OS, Iodé.

Made some mistakes. I did not unlock_critical (skipped reading that bit) and probably a load of mistakes I don’t even realise.

Device was stuck in booting a number of times.

Now I have TWRP and /e/OS but there are some problems:
When changing slots from fastboot: error: Device does not support slots
when “flashing unlock_critical”: FAILED, as any other lock or unlock
when flashing the /e/OS images: half of them skipped (can not write to critical partitions. Something along that line.
Volume-UP and USB-power is only way to get to TWRP.

I must have messed up partitions and boot(sectors?) Is there a way to solve this?

Now I am here anyway: is there a book/guide/site called “android from A to Z, the ultimate guide for playing around” ?

Well: thanks for reading this far, Robert

1 Like

Hi Robert,
is TWRP already officially supported for the FP4?
Else wie recently see some issues with flashing OSes on the FP4

Maybe you find some hints in the other topics already
https://forum.fairphone.com/search?context=topic&context_id=79634&q=fastboot%20%23help:fairphone4%20order:latest&skip_context=true

1 Like

I think it’s no good idea to install TWRP.
Did you already try to thoroughly follow all steps of https://support.fairphone.com/hc/en-us/articles/4405858261777?
Still if fastboot flashing unlock_critical does not work you might have a problem… (maybe you locked your device and oem unlock was not allowed in developer options…? :thinking: )

1 Like

Hello Angels,

Installing TWRP probably not a good idea. Agreed.

Back to FairPhone OS via your link: good suggestion but stuck in flashing first image. error: not allowed to write to critical partition.

But. I have Iodé running. Vive la France!
fastboot flash recovery_a iode-2.3-20220126-FP4-recovery.img
fastboot flash recovery_b iode-2.3-20220126-FP4-recovery.img
then reboot to recovery (iode)
then wipe /data format /data and /metadata
then adb sideload in iode-recovery
then from laptop adb sideload iode-2.3-20220126-FP4.zip

all without a single error !

My banking app still not working (because unlocked bootloader?)

But I will be content so far. I will leave it here and enjoy a working phone. Until next week that is.

Thanks, Robert

1 Like

Congrats for being back to a working system!
And good to know this way can help in case of problems with unlocking critical partitions!
Might it have worked because in your case the according slots were still flashed with previously installed IodéOS?

Can’t say for sure regarding Iodé. But knowing about /e/OS - which is probably similar in this regard - some baking apps don’t work with customROMs independent of the fact if the bootloader is locked or not…!

If it is not working without a warning then it’s because of missing goolag services

If it is not working with a warning, like your device is rooted, then it’s because of unlocked bootloader

But I’ve never had this case.
Nearly 100% of missing goolag scrab

Last working OS was /e/OS (on top of TWRP) and not Iodé. So I think Iodé did the trick. I dare not try to lock or unlock_critical. Maybe tomorrow. I am not really (or not at all) sure what I am actually doing . . .

1 Like

Don’t even know what reply button to hit. Sorry. Previous post was in reply to Volker. Obviously.

Banking app does give a warning: Link can not be activated. (in Dutch)

In MicroG - Google Safety settings - Test safetyNet attestation, it says: warning: CTS profile does not match Bootloader is not locked.

Shall I try fastboot etc.?

Read the last posts regarding this in the beta TG group of iode…

Ahh… TG stands for Telegram. Right? I will.

1 Like