My FP4 can't connect to the mobile network

Hello, since yesterday my FP4 no longer connects to the mobile network. The funny thing is when I turn on LTE and the 4G icon comes up, it reconnects and I can make calls.
But as soon as there is no more data transfer, i.e. the 4G symbol disappears, the mobile connection is also disconnected again.

If I briefly deactivate the SIM card in the settings and activate it again, I get a connection again for 1-2 minutes and the whole thing repeats itself.

My question is, is this a software problem (FP4 is up-to-date) or a hardware problem (wanted to order a new SIM card)?

Welcome to the forum!

I assume that you have already checked that mobile data is turned on for your SIM? That it works while making phone calls on 4G makes me think that it might not be the case. Did you install an update before this happened by any chance? (The updates seem to turn off roaming and/or mobile data for some people.)

Which provider do you use?

I think that would be wise.
I rather suspect that this is a problem on the network operator’s side, but it’s likely to take some time sorting it out. It may also be a problem with the SIM itself. Getting a new SIM will likely sort the problem although it may cost you 10 € or so.

However, first check with the operator to see whether they are reporting any network problems at the moment.

No, not even an app in two weeks

The provider is O2, I use them for about 4 months.

Thanks, then I’ll try this.

I assume Germany? then you should try to disable VoLTE and/or 5G. There seem to be issues with O2 which could be solved by this.



Thanks for your additional details.
If you’ve been with O2 for only a few months that excludes some of the reasons for getting a new SIM.

Follow Yvonne’s advice first, disabling VoLTE and 5G (basically fall back on 3G) and see how you get on. But for me this adds weight to the possibility that the problem is with the operator and not the phone itself.

If its Germany there is no 3G. Also disabling 5G still leaves 4G. For calls disabling VoLTE means the phone will fall back to 2G, but only for calls, for mobile data you will still have 4G. I would def not directly diasbale both, but see what helps best.

I’m going to try to keep the VoLTE off. I have already ordered a new SIM card, but if this is so, as you all assume, then this seems to be a problem from the network operator O2 Germany.
Thank you so much for your help.
If there are any problems, I will report back
You all have a great weekend


Hey, I´ve got exactly the same problem as you. Whenever I turn my mobile data off there is no network anymore. But my network provider is Vodafone and my friend who has the same problem is with Mobilfunk Debitel. So I guess the problem is not O2 in general. Also I don´t find VoLTE in my settings. Where can I turn that off?

Hi Andi5 and welcome to the community forum!

Please could you confirm your problem: that you cannot make or receive phone calls unless mobile data is turned on?

VoLTE means the use of LTE, a standard for mobile wireless broadband (i.e. “data”), to carry voice calls. It is often also referred to as “4G calling” because it only became possible with 4G. However it is not limited to 4G.

There is a lot of confusion over the various terms VoLTE, LTE, 4G and 5G, partly because these technologies have a complex history and are in many cases interdependent. I do not wish to add to the confusion.

On your phone, if you go to Settings > Network and Internet > Mobile network, you will likely see an option called “4G Calling”. This allows “use of 4G services to improve voice and other communications”. From what you have stated, this is presumably turned OFF at the moment on your phone. If you turn it ON you shouldn’t have to turn on DATA to make calls.
Let me know if I’m wrong!

Reading this I"m wondering if its not the opposite? With mobile data turned off VoLTE is not usable as depending on the 4g/LTE network. So wondering if its on and fallback to 2G network for calls not possibel/working?


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.