My Fairphone has instant charging capabilities :)

I found it unplugged and the battery at 45% charge this morning. I plugged it in and it instantly jumped to 80%:

I guess the battery really was at 80% and the phone - or the power chip - thought it was at 45%, and it came to its senses when I plugged it in somehow. Weird…

I’ll keep watching it to see if it does that again.

1 Like

Try running the battery down to 0, then charge it up to 100% without starting the phone. Then start the phone and notice what value it’s at. If it’s at lower than 99, charge it back up again and restart the phone again.

Maybe you just need to calibrate the battery.

1 Like

I did a “full reset” not too long ago. But maybe it got its brains all frazzled when I tried to control the phone’s charging with a Chargie dongle the other day, and the Chargie kept turning the power on and off several times per second for an entire night. The phone sure didn’t like that and crashed so hard that I even had trouble restarting it.

I’ll redo it I guess.

1 Like

This might also indicate a battery problem. I’m not sure how this particular (FP4) hardware does it, but in many cases battery charge is only estimated based on voltage levels. Especially when the battery starts breaking, a little extra charge can change the voltage so much that the indicator is not really reliable any more - but that is lost just as quickly again.
So while I hope that it’s only a calibration problem, you should keep that in mind. For extra assurance also check if the battery has become bloated or otherwise visibly damaged.
(Of course the battery should not break after such a short time, but there can always be quality issues.)

1 Like

I sure hope the battery isn’t busted after only a couple of weeks, during which I only charged it to 100% twice and discharged it under 20% once :slight_smile: But yeah I guess anything it’s possible.

The good news is, it’s replaceable!

Are you sure it jumped to 80% instantly or did it maybe take like 15 minutes?

The graph doesn’t look that weird to me, considering the whole time span is about 3…3.5 days. The Fairphone 4 specifications state:

50% charge in 30min with minimum 20W charger

Yeah it took a split seconds. I woke up, checked the SoC and saw 45%. So I plugged it to my laptop (slow charge typically), left it on the table for a minute to go get a coffee, and when I came back it was, well, maybe not 80%, but 75% or something. It went up to 80% after slow charging for a while and stopped there, because that’s the charging limit I set.

1 Like

That really sounds like an uncalibrated battery at best, or defective battery at worst. It would also explain your problems with Chargie. I would strongly suggest calibrating the battery and if it doesn’t help, you should contactsupport.


It’s probably graph related. You’re squeezing 3,5 days of power usage in that statistic, anything will look like a spike in that case. Charge it to 100% to reset the graph and try again, you’ll see the graph is less dramatic. I can’t even see my battery stats due to a bug which is plaguing the stock ROM for months already.

1 Like

I think the Chargie thing is unrelated. The maker of that little Gizmo sent me a updated APK that’s yet unreleased to test out and it worked just fine.

I’ll give the battery a good discharge / charge cycle and see what’s what.

1 Like

Well I didn’t run it down to 0% because I don’t want to stress the battery for nothing. 15% is enough. Now it’s slow-charging back to full outside of the OS.

I used the phone normally to discharge it - a few emails, a few phone calls, a few Signal calls, some GPS navigation, some music, some Youtube videos., some browsing… and I left my SSH tunnel up constantly, which does tend to burn some battery because of the keepalive packets. Otherwise, all in all a fairly typical usage pattern for a boring-ass Gen-X’er who doesn’t do social media or gaming on his phone :slight_smile:

It looks like I’d get 2 solid days of use if I ran the battery into the ground:

I’ll wait until the battery charges back to 100% and I’ll reboot, see what the OS says. That should calibrate it good I reckon.

EDIT: it took 3 hours to charge all the way and the OS reported 99% upon restart. So I’m guessing it’s all good.


Nothing there sounds alarming to me, so maybe it was just some (software) glitch. As already pointed out before: The onboard battery stats are not really great and I don’t rely on them very much for that reason.

Yeah I’m not worried. The instant charging was almost certainly a glitch. Still, it doesn’t cost anything to run a full discharge / cycle for good measure.

1 Like

Sure, it was certainly good to verify that. My whole statement is based on your new findings, after all :wink: