My earphone with remote and mic can't work completely

I have a earphone with remote and mic for Android but it can’t work well.
It should remote control music player with double/triple click to skip to next/last song but it doesn’t only on FairPhone.
Even i use the APP called “Headset Button Controller” or changed many different music players, the problem is still there.
I hope the bug can be fixed when FairPhone OS upload next time. And if the built-in music player adds “sleep mode” to control music stop after a period time will be better.

I do have the same problem with my remote control, the only thing ist does, is pause/play .

Same problem. I tried several earphones and several APPs but nothing works to get more than stop/pause.

Same Problem here. But habe not found a solution. Maybe the only way is via a Software update by FP?!

I use an Android headphone with the Poweramp Music Player and double clicking does work. It needs a special timing, though. Not too fast, not too slow. Maybe you just have to try a little to find the correct clicking speed?

On my old phone, I used Jays Headset control, which always worked excellently. No clue whether it plays nice with the FairPhone, since mine still has to arrive :).

1 Like

I read, that some headphones are designed specifically for Apple devices.
Their in-line buttons apparently only get recognized by Apple’s products and don’t work flawlessly with android smart phones as signals (which are digital) are processed differently.
For example: My skullcandy headphones say they are apple compatible and I experience the same issues with these as you do, that is only one button working. My mic works, though :smile:
So if your headphones were designated as iPhone compatible that may be the problem.

Great Info. I just installed the app and now it works real good.

Now I can switch to the next song by tapping three times, one time is for pause and then two times for the next song.

Thank you.

What is your headset timbuktu? Mine did not work even with the Jays Headset control app. Even with the “Jays - a-JAYS One+ Earphones” I bought especially (and finally returned).

My Headset is from my old Palm Pre3. It has a one button control panel. PalmHeadset

Thanks timbuktu. You own kind of a collector headset here :wink:

Hi guys,

My gf got me Bose Quiet Comfort earphones for Christmas (supposed to be Android compatible), but nothing on the 3 button remote seems to work: + button, - button, middle button, microphone. Is there a chance that it is just a software issue?


What did you do in the end? Did you find a solution? Nothing works on my remote. Thanks.

Maybe you need a special Bose app. I see there are some in the Play Store.

I’m trying to go through them but nothing convincing so far. Is it clear for you that it is a software issues rather than hardware incompatibility? Thanks!

If they say “Android compatible” then I assume so. I do not have experience though, as I do not use headphones with a remote.

Just to clarify: We are talking about wired headphones, aren’t we? I mean, you don’t connect them via Bluetooth?

I have the same headphones (@Stefan: Yes they are wired).
Mine came with one wire without and one with a remote.
The remoteless wire works perfectly for both Fairphone models.
The wire with the remote can only pause on the FP2, but not change volume and with the FP1 the remote doesn’t work at all and it produces static sound.

1 Like


No they’ve got a wire:

Maybe I could contact the fairphone support directly…

Thanks for yours,

Hello everyone. Has anyone contacted Fairphone support on this issue? I can’t use the remote on my Bose Quiet Comfort 20, nor can I use them to answer calls: I can hear but the mic’ doesn’t work…
I asked in a Bose shop: they really think it’s a hardware problem and told me no Bose app. will solve the problem…