English

My computer don't show my fairphone anymore via USB

same me! I have the same problem but on a macbook.

First start of your ubuntu should give you lsusb (just return) to find the most simple usb device list with a line starting like (not precise)
Bus 002 Device 003: ID 2ae5:9039 … after ID it must be precise in only one line of output

Also after immediately re-plugin of FP2/usb output of dmesg (return) gives you
usb 2-3: new high speed USB device using ehci_hcd and address 3
usb 2-3: New USB device found, idVendor=2ae5, idProduct=9039
usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-3: Product: Android
usb 2-3: Manufacturer: Android
usb 2-3: SerialNumber: (xxxxxx)

After starting ubuntu make sure you have internet connection including functional apt-get or synaptic . You need mtp-tools to analyse your FP2 with usb connnected. Find it by dpkg mtp-tools or install it by apt-get install mtp-tools.

Then you find mtp-tools for mounting your FP2 SD card by reading manual page : man mtp-tools. Also I could give you another lesson with mtp-tools commandline. No, no windows graphics tools, no icons and nice little pictures. Only commandlinle given and driven.

I had the exact same issue with FP1U, I’ve just fixed it by wiping data from the Android app managing the media storage on the phone:

Settings > Apps > “All” tab > Media Storage > Clear data > Unplug USB > Plug USB

Hope this will do the trick for you too.

2 Likes

I also have the same problem. When I connect my FP2 with my PC via USB cable, the FP2 is charging, but I can’t choose the mode, nor can I transfer data. I tried different cables and Judas Trick (Settings > Apps > “All” tab > Media Storage > Clear data > Unplug USB > Plug USB) but it didn’t work. This problem also appeard after a software update. Before it worked.

Sidenote: I tried it with bluetooth and it also didn’t work…

Ok, now it’s working! I tried a third USB cable. Obviously there are USB data cables and USB non data cables…

Aka USB charging cables. But these don’t work well for charging a Fairphone either, see:

Mine is USB data cable, when it was working i was transfering files without any problems…

Don’t work…

Thanks.

Wow!

Okay, that work again now, i’ve uninstalled the SDK from android, and it’s working again… That just come back to my brain, that i was wanted to try that few month ago than it just leave my brain!!

Thanks you all, for the help!

THAT worked. Thanks a lot. This IS a software issue under FP2, regardless of computer OS or usb hardware, and it does happen randomly. That stuck me at work because i use 4G from my phone. Glad there is a workaround, but it’s mandatory the tech team digs into this bug.
Thank you Judas.

I have the same problem, is there any how-to on trying to uninstall the SDK from Android? or someone to talk me through it?

Hi,
I had this problem as well, and “solved” it, by deleting everything and starting new. After the reinstall, MTP-connection to my PC worked.
Today I can’t see my FP2 in my Explorer anymore. Same cable, same USB-Port. Mounting the SD-Card works, but that is not a solution for me.
I tried clearing the Media Storage App data, didnt’ work.
Does anybody have a solution? I would hate to have to reinstall EVERYTHING.

Have you already restarted both devices (FP2 and PC)?

Now, yes. No change. :cry:

Maybe your microUSB port is broken. Try it with a new bottom module.

I have exactly the same problem:

  • FP2 detect when connected to a USB charger. It charge correctly.
  • FP2 don’t detect when connected to my PC by USB. And don’t charge.
  • When USB is connected, FP2 don’t show the notification to choose between charge, MTP, etc.
  • On the PC, when FP2 is connected, dmesg and lsusb doesn’t show anything about any connected device. My computer don’t see the FP2.
  • USB cables and PC are tested and OK.

This is how I (temporary) fix this problem:

  • Activate the developer mode on the FP2
  • Go to “Settings” > “Settings for developers” > “Network” section > “Select USB configuration”
  • Choose “MTP” manually.

This look like a bug. My version of OS are: Fairphone Open 17.06.4

2 Likes

I have exactly the same problem.
but since I updated to Fairphone Open 17.11.X it charges, if I plug the USB cable slowly .

7 posts were merged into an existing topic: Awkward battery charging

A post was merged into an existing topic: Awkward battery charging and no connection to PC

Same problem here.
Data transfer via USB was fine. But after I updated to build fp2-sibon-18.02.0
the phone did not react to an USB connection to my desktop at all. There were no logs on the desktop, either (Debian linux buster/testing). USB charger worked as expected, though.
This is with the same cable, same USB receptacle on the same desktop as before. Changing any of these usual suspects did not affect the problem at all.

What did work, was the a similar fix as presented by SebG above. That is:

  • activate developer mode (by tapping the build number several times in the about phone screen)
  • activate ‘USB debugging’ in the developer options

With this in place, my FP2 reacts as expected when it is connected to my desktop via USB. I immediately get a response and can choose the USB mode from the notification tab. This still works after a reboot and even if I disable developer mode.
( Settings → Apps → Settings → Storage → Clear_Data )
So it looks like USB connection to a desktop requires ‘USB debugging’ activated. With hindsight, it may have been me fiddling with developer mode options rather than the update. Not being able to connect properly to a desktop without ‘USB debugging’ enabled is a little surprising, though.