My camera stopped saving pictures on the SD card

Hi, I’ve been using the camera for long, saving pictures on the SD card. All of a sudden, I cannot take pictures any longer: the camera appears as if taking them, but they are not displayed in the preview inside the camera. I sometimes can access those “pictures” via the camera, selecting the share option. However, they appear black and have a file size of 0.
Those “pictures” also don’t show if I open the folder “pictures” (not even as black pictures). They are also not stored in the folder SD card>DCIM>Camera (where all the previous pictures have been stored and are still accessible).

I did not change any of the settings.
There is still sufficient space on the SD card.
I restarted the phone, this did not help.
Current version of Android is installed.
I re-set the camera to the standard settings, which did not have any impact.

Changing the settings inside the camera to save on the phone instead of on the SD card allows me to take pictures again.
So it seems as if there is some miscommunication between the camera and SD card…

Any idea how to make the SD card accept pictures again?

That sounds like a broken SD card to me. Have you tried if you can still save other files on the card or how it behaves when you take it out and plug it into a computer?
I had a similar problem a few weeks ago. My phone acted very strange, stopped downloading podcasts (to SD) and so on. It then turned out that the SD card was broken and Android was not able to properly convey that message to me, instead simply treating it as read-only.


Possibly Android has no other choice.

I have several old SD cards and USB sticks lying around which at some point suddenly stopped being writeable, apparently by decision of their internal controller.

There’s a bunch of low-level formatting or reset tools out there in the internet for such cases, but I didn’t have any luck with any of them.

I disagree slightly: Android could simply tell me that my SD is not writeable any more - as it is already responsible for having remounted it read-only. Instead it lets apps randomly crash and burn. :slight_smile:
There are notifications for everything. Why not for something basic like that?


Hi and welcome to the forum.
I wonder how you formatted the SD card. If it was as an extension to internal then that is likely to be the problem.

Can you check not just how you formatted it but what memory you have left and what camera app you use.


You ideally will have

  • more than 4GB left on the main memory and
  • you can see the eject icon to confirm the SD card is portable/external

You will also want the default or open camera app so that you can store on the external SD card or with other apps (Gcam versions) regularly move the photos from the main memory to the SD card

Thanks for your recommendation…
I can see the Eject icon, and I still have more than 7GB of free space left (and even more on the Phone itself).
For the camera, I guess I’m using the default app: it’s called “Camera” and has version 2.0.002 (gms-31ddee-00). I used to save the pictures directly on the SD card, but I’m no longer able to do that).

I also tried to follow @mde’s advice: I’m not able to move files from the phone to the SD card… Next, I’ll check how the SD card behaves if I plug it directly into a computer.

1 Like

Hi It sounds as though everything is in ‘place’ for it all to work.

Checking the card in a PC is a good idea.

By the way if you have another SD card that is ‘free’ you can insert that and format on the phone as portable/external to see if that is able to save images.

If that works then the next options would be to ensure the phone hasn’t had some ‘disturbing’ damp which may have tarnished the SD card slot contacts, the sd card is easy to clean.

You may also try starting in safe mode, which disables all custom apps that you loaded etc. On a normal restart you would then have to ‘enable’ each app with ‘signing in’.

A factory restart would be the final option as that would erase all your data.

All the best

1 Like

the old SD was still accessible on a PC.
Still, I tried with a new SD card which I formatted as “internal”.
This resulted in total disappointment: I cannot store any pictures any more, I cannot download pictures or attachments from Whatsapp, I cannot take pictures inside Whatsapp, I cannot download documents from the internet.
I’ve now saved my contacts.
Any suggestions what to do instead of de-installing any app and trying to re-start in “default” mode (no idea yet how that might work)?

This is the problem. Countless users have reported exactly your problems with this setup. Re-format the card as “portable storage” (see amoun’s suggestion above). This does not allow to install apps on the card, but you can move photos, music, videos to the card manually (e.g. using the “Files” app or another file manager app).


Thanks a lot - formatting as “portable” seems to have solved my issue :smiley:


A post was merged into an existing topic: FP3 Android 11 Video and Google assistant bug

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.