Mobile Reception Symbol Error

Hello Everyone,

I have a somewhat strange problem:
The symbol for mobile reception has a little cross on it when no wifi or mobile data is enabled and as i understand it, it means that i got no connection. The strange thing is, it works nonetheless, SMS, Calling etc. (Top in the picture)
When i turn on my mobile data, the little cross vanishes and everything looks normal. (Middle one)
When i am connected to any wifi, the cross reappears. (Bottom)

I only noticed it recently after a business trip where is used roaming and hat some Mobile data issues upon return. (Whatsapp worked with mobile Data, no browsing possible, but a reset of all network settings helped)

So now to my question, has anyone a similar problem, an explanation, or a fix to this?
Or is it normal? I have got the phone only a few weeks and may have not noticed this.

Additional Background info:

  • Provider is Vodafone Germany
  • I cannot edit APN settings, they are greyed out
  • Problem doesn´t appear on another mobile phone with same SIM
  • Phone is up to date
  • Phone was set to factory defaults also

I mean it doesn´t bother me too much, as long as it works, but it also kind of annoys me that it looks like something isn´t working.

Thanks for your help and input.

1 Like

Welcome to the Fairphone community.

It’s not a problem but normal, the ‘x’ shows, that there is no internet connection via mobile data. So it works as designed.

6 Likes

Ok, thanks for the reply, i just wondered why the X is needed, i mean there is a separate Symbol in the status bar that shows if i use mobile data.
The only thing i found to this issue was, that the x stands for no mobile rezeption as in “no calls possible”.

The icons are not ‘universal’ Many phone manufactures adapt them, even the default Android doesn’t show the network with the cross to the bottom right. However Xiaomi do have a similar one with a cross top left.

The page below isn’t definitive just a collection someone has made.

Thanks for the Tipp, on the website you suggested was a link to Material Symbols and Icons - Google Fonts
and in the category “Device” i found it
2022-06-09 12_09_15-Material Symbols and Icons - Google Fonts
So Icanus was right in the first place, so it seems every fairpone 4 shows this icon when mobile data is not enabled.
I still find annoying but i think there is nothing i can do about it.
I am just used to the normal cellular signal bar, because if i enable mobile data it already shows me if i´m using 3G, 4G or 5G so i didn´t think it would additionally show data availability in that icon.
Thank you :slight_smile:

2 Likes

A Pixel 4a I checked is using an ‘!’ instead of the ‘x’, the FP3 works exactly like the FP4. I think that’s helpful, because no 3G, 4G, 5G can also mean, that there is just no data connection at the moment, whereas the additional symbol shows, that it is deactivated.

4 Likes

Hi @davidd, many thanks for your post!
I had the same problem: no mobile data on my FP4, signaled by a small cross in mobile network field strength indicator. Provider also Vodafone Germany.
As you suggested the problem was solved by a ‘reset of all network settings’.

Vodafone said it’s a problem with the SIM card and was about to send me a new card. No idea if this would have helped, too.

To whom it may concern:
My assumption is that problem ‘no mobile data’ was introduced by updating (keeping my FP4 ‘up to date’) to firmware FP4.FP3W.A.128.20220516 that I ran as soon at it became available some days ago.

2 Likes