Mobile Internet doesn't always connect

Hello,

I’ve had a look in the forum, but haven’t found anything equivalent.

I have intermittent Mobile Internet problems. WiFi works fine. Basically, even with Mobile Internet ‘on’ it doesn’t always connect (ie. the little ‘3G’ or ‘4G’ symbol doesn’t appear) and I can’t connect to anything. This probably happens 50% of the time, when for example, I leave a WiFi area/turn off WiFi or turn on my phone without WiFi enabled.

I’m in the UK and on giffgaff. I’ve entered all the APN settings given here. I have tried turning Mobile Internet off and on again. I’ve tried enabling and disabling Aeroplane Mode. Most of the time that doesn’t work. What seems to work more reliably, is moving from one area to another (changing cell towers?).

Any help diagnosing this would be greatly appreciated, as not being able to access the Internet has caught me out a couple of times already :blush:. I guess it could be a giffgaff problem, but it seemed more like a phone issue. I recently added a second SIM card (Phone Co-op), but this was happening beforehand with just the one SIM card.

Otherwise, Fairphone is the best and looking forward to Android 7.1!

Have you (since you are now on dual-sim use) rechecked both sim network settings for data? One needs to be set to 2g for phoning, the other may be 3g/4g. If 4g coverage is unavailable or too weak keep it at 3g only to see if a stable connection is established.

Do you know about your areas network coverage? Have you checked at a more distant position for a stable connection?

Also you could see if both cards are connected by using the supplemented checkup diagnose tool at settings->maintenance->checkup->mobile connectivity.
Have you possibly tried the same sim card(s) in another phone to be sure it´s no provider problem?

2 Likes

Hi @Patrick1. Thanks for the help.

I don’t have a 2G option for either SIM card. If I go into Settings -> More -> Mobile networks, I can only choose ‘4G (recommended)’ or ‘3G’ (for which both are on 4G). There is no 2G option. In the Mobile Connectivity menu, the main SIM card shows ‘Network type: LTE’ and ‘Mobile data connected: Yes’ even though there is no Internet. Interestingly, the 2nd SIM card shows ‘Network type: UNKNOWN’.

Network coverage has always been good in my area, but good point about trying a different position and phone. As I don’t need the 2nd SIM card again until next week, I’ll also trial on just the one SIM card and see if that solves the problem. And to cover all bases I’ll get a replacement SIM card :slight_smile:.

Also, I found this:

Could be an issue with both giffgaff and Phone Co-op?

This is a minimum network option which should always be available as classic mobile phoning usually works with this network type.

This seems to be the problem. It is the default factory setting of Android 6. Although both slots are equal there in only one transceiver available.

If you are sure both cards should offer high-speed network there is actually only one connected that occupies the transceiver already.

The proper constellation as I know it should be is: one sim set to 2G, the other to 3G/4G.
If set up properly once, the software won’t let you select both cards to 3G/4G anymore. You may set both to using 2g though (this is based on the Dual Sim Dual Standby hardware layout). But the default factory settings are wrong and seems to cause troubles for the ones starting off with dual-sim as there were others in this forum facing the same start problems.

We need to get a correct network settings constellation which only lets you select compatible combinations. I think this only has to be done once.
There are different ways to solve this. I would advise you to do the following:

Switch off your phone and remove one sim card. Which slot to use is totally up to your choice as both are technically equal. Power on and enter the network settings of this card. There should be the 2G option available now. (If not, try the other sim card). Once you can select 2G, do this.

Switch off again and insert the second card, power on again. The network settings for the second card should now also allow 2G, chose it as well.
This is a basic constellation for a dual-sim mobile just for phoning.
If everything went well it shouldn’t be possible anymore to set both cards to 3G/4G at once, only one or the other while there is always one limited to 2G (greayed out).
You don’t have to swap slots anymore as all is done by software now.

Usually there is not much to be done for phoning via 2G. But setting up the high-speed network by selecting 3G/4G may work flawless if the network selection is done automatically. Nevertheless there are providers where the user has to take some manual actions for a proper connection. These settings should be easily available from the provider, some even sent them automatically to your mobile.

Hopefully all turns out to be fine now.

4 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.