Mobile data not working on Utility Warehouse (UK)

Hello!
I bought a brand new Fairphone 4 direct from the Fairphone website early January. I haven’t been able to get my mobile data to work. I am able to send texts and make phone calls, it is only internet access that is having issues. I have tested the SIM in another device and it worked just fine, so appears to be a phone-side issue.
My provider is Utility Warehouse and I’m based in the UK. Their support has confirmed there are no bars on their end (though my plan does not cover 5G, if that could be relevant?) and that there is good coverage in my area.
I have tried with an APN added and without (UW’s support told me I don’t need an APN). I have tried automatically select network (which found UW) and manually selecting it. EE Wi-Fi calling is off. System is Android 13.

I have conducted all of the other troubleshooting I could find on the Fairphone support page so I am completely at a loss!

You need an APN set up properly to have mobile data…

3 Likes

I literally had someone else set up and also tried setting it up myself, and it didn’t change anything. I’ve just given it a go, again, using the same webpage to provide the information… And it worked! No idea where the typo was. Thank you for getting me to give it another go :slight_smile:

4 Likes