Mobile data connection breaks after few minutes using dual SIM

Since several weeks I have severe trouble with mobile data:

  • It used to work fine for several years
  • I do have SIM (Telekom) and eSIM (1&1)
  • When the error occurs, I do not get mobile data connection anymore, I can switch the provider/SIM, I can reset network, I can change or reset APN, I spent days and nights reading the web and troubleshooting the problem but nothing helps
  • What does help is to reboot the phone, then the mobile data connection is working find for a few minutes until it stops working out of a sudden. Then both mobile icons in the top bar show an exclamation mark. Chrome says it is offline, messengers not working, etc.
  • I also rebooted my phone in “safe mode” and observe the exact same error.
  • Sometimes when I reset some network settings, the mobile data connection comes back for some seconds or a minute but then gets broken again.

I conclude the following:

  • It is not a general outage or data limit issue of any of my mobile internet service providers!
  • The problem occurs with and without 5G enabled.
  • It is not that my hardware (mobile chip) is generally broken but still it is unclear to me if I have a hardware or a software issue.
  • The error happened closely to a Fairphone update but I can not tell for sure that it is related. Since then I got another minor update and that also did not make it better or worse (I hoped it would fix the problem but it did not.
  • WiFi is working fine so I have a workaround when at home but no internet on the road is a big issue for me.

What can I do? Is there an app that can show logs and give detailed diagnose infos?
If Android cannot connect to mobile network, there should be some kind of error message but all seems to be carefully hidden to the end-users. I would like to trace down further and know if I do have some hardware damage or a software issue.
I just installed “Logcat Extreme” and see some warnings with “Parcel: Expecting binder but got null!” but have no clue how it is related. Only errors I see are from OpenGLRenderer what does not seem to be related at all.

Can you please share your exact OS version?
Maybe I missed it in your description: in case you use only one SIM (and eject the other one from the beginning), does the problem also happen (i.e. it happens on both SIMs configured from the start and with the other SIM not included)?

I’ve the same issue on both the physical and the esim. Support has no answer yet. Only since the last update with 5G enabled.

Well for me this happens also with the esim so it’s not related to the physical sim it seems.

1 Like

Ok it does only happen with the esim. Totally random and suddenly: phone lies in front of me with approx 75% connectivity and suddenly it’s gone.

So weird.

New workaround: only turn off the data connection for a second and back on, and all’s fine.

The esim is my standard for data connection.

1 Like

Ok with the latest Fairphone update from 19.02.2024 the connection isn’t lost anymore so far. Let’s see on the move and public transportation how it’ll behave…

Update: tried troubleshooting as said by support but nothing changed. Only since the pre-last update been ongoing so 100% certain that this caused it. With an esim it’s also certainly not related to that as it’s being updated automatically in the background in case the provider changes things such as Apn or something alike.

Seems to be caused by some malfunctioning connectivity code within the pre-last Update I suppose.

Temporary workaround: shortly turn off and on again mobile data, this immediately forces a new connection it seems and all good until the next time. Then same procedure. Annoying but at least a workaround for now.

1 Like

Update: unfortunately so far Fairphone didn’t find a solution. The issue is in particular very irritating while being on the move as e.g. on a fast train. Before the mentioned Update this issue never happened. Being stationery the workaround is still very briefly turning off and on again the mobile Internet connection. On the move that doesnt solve the issue. Seems something with the triangulation is wrong, meaning that the FP doesn’t flawlessly switch between cell towers but rather loosing the connection totally while switching to another cell tower. Happenes with two different Providers both on 4G/5G.

Anyone else can report something on that issue and might have found a workaround that’s any different?

So also with 5G off? Did you try with VoLTE off? Did you test with only one SIM enabled?

1 Like

Tried all that but nothing helped.

Short update since @yvmuell triggered an idea: tried again all various setting combinations and maybe I by accident found a (kind of weird) solution: the secondary sim (physical) was only allowed to use data while being on a call. Turning VoLTE off for that sim didn’t do it though it then shouldn’t use data. Now also preventing it to use data during a call seems until now to fix it. Couldn’t test it yet at higher speeds as e.g. trains or motorway but at least locally and indoors I didn’t experience that issue again so far. Perhaps this helps someone else too.

Once I have more experience with that new workaround I’ll post it here.

1 Like

Can you specify that setting?

“use mobile data during calls” is now off. It’s within the SIM card settings and in that case the secondary one.

This setting seem only to be available for the SIM not used for mobile data, havent ever noticed that setting so far.

Not sure how this works normally, would inform support it does seem to provoke issues…

1 Like

Already did. Thanks for the hint to once again check all settings. Again, curious how it’ll behave at higher speeds of transport since the network triangulation then is much more work for a phone…

1 Like

I’m constantly loosing it the moment it (obviously) switches cell tower

Can report that my “fix” only makes the issue less bad but still occuring during commuting. Got better in the sense that it did occur on the same ride approx 5times in 20min and now only 1-2 times.

Ok I can report that the issue still prevails with the latest update and it is also still very annoying while commuting/driving with higher speeds.

My fix as described isn’t a fix but as already said makes it less frequent and thus a bit less annoying than before.

I tried to remove the physical and esim and then put everything back and set it up again. No changes. My bug seems definitely software related since nothing in terms of troubleshooting worked so far.

Furthermore, prior to the mentioned Update that never occured. Very annoying bug.

5 posts were split to a new topic: Mobile data connection breaks using only 1 SIM from Telia