MMS, sending and receiving pictures

I can’t send or receive photos in messages with my FP2. I tried to sort it out through my phone subscription company, but their suggestions did not help. I’ve since (for three weeks) tried to get a hold of support, but with no success, has anybody else experienced this issue and have a solution to the problem?

I have a similar problem with FP1 Can’t send photos but can receive them. Seems to be a storage issue although I have been deleting lots of data and underused apps

I can’t receive or send via the Messages app either (UK Virgin network). Virgin says it has “sent MMS settings” but both send and receive fail.

I have the same problem with the Norwegian operator Telenor. They have not been able to help - it seems that the Android OS for Fairphone 2 is modified in some way that makes it difficult to get the settings provided by the operators correct. Would be great if somenone in the Fairphone time could help with at trobleshooting7set up guide!


Hello, I have had the same problem (impossible to send long SMS or MMS) with my F2 and I finally downloaded a different SMS/MMS application : TEXTRA. I don’t know whether the problem was with Android or Fairphone but it now works. On the other hand, I can’t seem to be able to send pictures with the application What’s app (I didn’t have this problem with my samsung), so if you have a solution, I am all ears !!


This is a known issue, just look a bit on the forum for the right topic. If I remember correctly, this is a “Privacy Impact”-problem.

For some users activating the Privacy Impact works, it seems. I fixed the problem by 1) deleting all APN accsesses listet except the one I use and 2) changing the text app to Hangouts. Hope this is useful for others as well.

I also can’t send MMS with both SIMs (FONIC and winSIM in Germany) to each other. They have the same network, but different APNs. But I don’t care about it. Who would send me MMS or expect receiving MMS from me? I think they would rather use e-mail (which is also cheaper and more universal).

Downloading Textra solved it :slight_smile: Thanks everyone for your suggestions!

I have the same issue (can’t send MMS), with FP2. I have TEXTRA (I also tried Hangout), it still does it. It’s especially annoying for sending pictures via text, or to send the same text to several people (it’s MMS in both cases).

I’m up for any suggestion !

I’ve read that some providers disabled the MMS service because of the stagefright bug last year. Maybe you should check first, if this is the case.

Any issues with Textra?
Is it free ?

No issues, works very well, free for about a month, then you have the choice to pay or go for a version with ads, I am using it with ads, and it very seldom I’m bothered with advertisements. Best, Ane

This many be old news for most people, and maybe not the issue that you are dealing with, but I had the same problem (not being able to send or receive mms) with my FP2. Then, after a couple of phone calls to the operator (the Norwegian company Chess), I learned that you need to turn on the cellular data to send and receive mms. Problem solved for me!

1 Like

3 posts were split to a new topic: :se: Sending & recieving MMS

Off topic: I tried Textra, but the emojis didn’t work. I downloaded the emoji apps (android and ios) but, nothing. So I went back to Messaging. I also tried Google Messages, and that didn’t work at all. I have also tried Hangouts, but that one uses only cellular data to send messages so I didn’t want to use it much.

The reason I have tried so many is that I use MightyText and I cannot find a way to be able to see the messages that I have sent from the computer on my phone. I can see the messages that I have sent from my phone on the computer. I read somewhere that this has been a common problem with MightyText, and that someone solved it by switching to Textra. I did not. So now I use Messaging, have Android emojis and cannot see messages sent from the computer on my phone.

What do you mean ‘turning on the cellular data’ ?

Some providers don’t allow MMS over Wi-Fi. So you need to be connected to mobile data in order to send (and maybe also receive) MMS.

Same problem here. MMS worked before the switch to FP2. To be honest, I blame the app. So, who do I need to contact since general support seems to deem that problem as “not important enough to react to it” (see OP).

I got this reply from support (and it solved the problem):
We improved the Privacy Impact behaviour with the latest software update, namely Fairphone 2 OS 1.3.6. You can find a list of the improvements and fixes in the related release notes.

Please make sure your phone is up-to-date by connecting to a Wi-Fi network and checking for an update with the Updater app. Check out our interactive tutorial for a step-by-step guide.

If it does not solve your issue, please check that the Privacy Impact popup is enabled, you may have to uninstall and re-install a misbehaving app after that to make it work normally. The Privacy Impact settings
are located in the phone Settings > Sound & notification > Privacy Impact, make sure to untick the checkbox Disable Privacy Impact popup to enable the Privacy Impact popup again.

For me the thing with the privacy impact popup solved the problem. On my phone it was already unticked, but I ticked it and unticked it again, and now I can send and receive mms. Hope it can help some of you.

1 Like