Missed Call from one specific contact not classified as Missed Call

Hi! I have one specific contact which I don’t get Missed Calls for. When she calls and I don’t see it, then there’s no notification on my screen and no small bubble on the phone app, so I have no way of knowing if she called, except for regularly checking my call log. And there the missed call is represented by a grey arrow pointing to the lower left instead of a red bent arrow. All my other friends show up as missed calls. I also deleted the contact, recreated it, renamed it, removed the ±Sign from the number, anything I can think of. I have no blocked numbers, I also tried disabling spam call recognition (don’t know how to translate that), still, no notification. I also tried using a different phone app, same result. I have absolutely no idea what could cause this. Next thing I’d try would probably be android debug bridge or something, but maybe someone here has any hints. My provider is O2 (Germany), I restarted the phone, I cleared the phone’s cache, tried every tip I found online and I don’t know where to look next. My previous phone (also android, same SIM, her number was also the same) never had this problem.

Hi and welcome to the forum.

Your friend may have caller ID blocked.

You don’t have a Do Not Disturb profile active by any chance? Some contacts may be blocked from showing up, depending on how you set it up. Although I’m not sure if it would have this effect.

You can also test if this happens in safe mode.

I’m not in Do Not Disturb mode and also enabled that all calls can cut through DND mode. I also have no blocked numbers.

EDIT: Also happens in safe mode :frowning:

As far as I can tell this is the indicator for an answered call - which also explains why it does not show up as missed in notifications. :thinking:
Do you know how the situation presents itself from the caller side? Does the caller get the normal phone ring or is there something strange on that side as well, maybe?
Is it possible that you have some sort of app installed or some sort of configuration that intercepts the call? The former should not really be the issue if it happens in safe mode as well. So my guess would be on some sort of Android setting (emergency contacts or such?) - or a real unfortunate bug.
I guess you’re not really in the mood to start fresh with a factory reset and see what happens? :see_no_evil:

Just for completeness: Which Android OS (Stock, custom ROM, …) and update version is installed on your phone?

1 Like

Android 11 (Stock), Security Update 5. February 2022, Google Play-Systemupdate 1. March 2022, Kernel-Version 4.19.157-perf+ (1. Feb 2021), Build-Number FP4.FP3S.A.010320220221.

I don’t mind a hard reset, if it has the chance of solving the problem. This issue really killed the trust I have in my phone. I mean, if it happens to one number, it can also happen to other numbers. :frowning:

Oh man, I got it. Although I don’t consider this a “real” solution, I post it here in case anyone googles this:
When I tapped on call details it would show me “The call was answered/taken on a different device” (direct translation from german “Der Anruf wurde auf einem anderen Gerät angenommen”). So I googled that and one advice was to turn off “volte” (Voice over LTE). I did that (it’s buried in Networks → Mobile Phone Networks → use volte) and now I see missed calls from her.
The reason why I don’t consider that a real solution is because voice over lte apparently uses the mobile data network to do phone calls with less energy consumption and higher audio quality. So while I wouldn’t have noticed it without knowing it, it still bugs me. Anyone knows why another device accepted the call, what other device that might be (she didn’t leave messages on my mailbox), what error might be causing this?


I have no explanation, however what phone did you use before and did you use it with the same SIM? I think I would call the SIM provider, maybe they send you a new one that was not registered in another device. Overall VoLTE is currently causing issues with O2

1 Like

That is really strange indeed and should not happen, I agree. But it’s great that you could figure it out at least.
It must be some sort of bug or misconfiguration at some point as this is clearly not intended behavior…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.