Miracast in LineageOS 16?

Bad news: I’ve finally given up hope that Fairphone will be able to get Fairphone OS back to an acceptable usability level. :disappointed:
Good news: I’ve spent an entire weekend migrating to LineageOS (+ Open GApps) and, while not perfect, I must say that it’s a significant improvement in both stability and features. Thanks a lot @chrmhoffmann! This prolonged my FP2’s life for a few more months (or years?).

One major regression I noticed and couldn’t find already reported here (correct me if I’m wrong): Miracast doesn’t work. The phone finds the receiver, but connection attempts fail or the phone crashes. Tried it with two different receivers. Can someone reproduce this (or was successful using Miracast with LineageOS 16)?

Not sure when I can try this, but will check.

1 Like

I now tried with my Samsung BD-J5500 Blu-Ray player and indeed it doesn’t work.

These were my steps

  • enable Screen Mirroring on the player
  • tap on “Streaming” in the FP2 quick settings and select the player
  • it says “connecting” on the big screen
  • then the display of the FP2 goes black (backlight still on), the big screen says “loading”
  • the FP2 kicks me back to the lock screen and the player says “screen mirroring stopped”

It used to work with earlier versions of LOS (14.1 and 15.1).

1 Like

Thanks for confirming. I tried it with a Samsung QM65H conference display as well as the Projecting to this PC feature in Windows 10 (on a Dell laptop).
Same symptoms. The FP2 screen goes black and it seems to “soft crash” (back to the lock screen, SIMs reconnect, WiFi reconnects).

Since you say it worked in LineageOS 15.1, there might be hope that it can be fixed? Now if we only knew someone who knows what they’re doing… :wink:

I confirm it was working before, I made some tests in the past. But I didn’t tested on LOS 16 yet!


Same problem here.

I found the following info:

Google disabled Cast, Miracast or WiFi Display in Pie.

In this LineageOS Gerrit search you can see that some devs for a handful of devices are trying to implement Miracast: https://review.lineageos.org/q/miracast+branch:lineage-16.0

Try also this search with a bunch of “Remove Wifi Display options” commits in the results: https://review.lineageos.org/q/wifi+display+branch:lineage-16.0


It now works again! The changelog for the 20190923 build mentions Miracast. This might have fixed it. :+1:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.