Middle of touchsreen not working after repair

I just changed the display assembly on FPU1 after dropping it about 10 m.
After dropping it, the touchscreen worked ok except for the lower left hand corner.

I ordered the new display unit and installed it this afternoon, and now the middle (and lower left hand) of the touchscreen doesn’t work. On the touchsreen test (✏ How to test your touchscreen for abberant behaviour (is it a hardware or software failure?)), it shows a black square in the middle. Occasionally, I can touch something in the “dead zone” and it registers, but it’s random (and rare).

I’ve dissasembled and put it back together 5 times now, and no luck -except for about 30 second when it worked properly, then it stopped again.
I figure something is misaligned (or I was very unluck to get a faulty display unit).
Any ideas?

Thanks for the help!

I’ve never heard of it, but it might be possible. Did you get in contact with Fairphone support?

Late reply, but yes I contacted them and shipped it off.
They repaired it at no charge and sent it back, so it seems it was indeed a faulty unit!
Works perfectly now.


Nice to hear it worked out in the end. :smile: