English

MicroSD card keeps disappearing from storage

Tags: #<Tag:0x00007f05d8d2afc0>

Hi guys

I unmounted my MicroSD card from my old phone to put in my new FP2. At first it showed it after putting it in a few times now it’s disappeared from storage in settings.
I’m not to pleased about it as this is a brand new phone and I can’t walk into a local shop to get it replaced. The SD card shows on my other phone with no problems.
Has anyone else had this problem and is there any fixes for it.
Any help welcome.

Thanks

Bas

1 Like

Does it disappear or just dismount/mount ?

Hi Jon

It was there yesterday and today is isn’t there. Amaze can’t see it and under settings/Storage there’s nothing there under SD Card. I had the problem first time I put it into the FP2 and unmounted it on my old phone before putting it back into my FP2 and then it saw it. Now it’s gone hiding again :confused:

Bas

hi there

I seem to have the same problem. SD-Card content doesn’t show and SD Card is not mountable in storage menu.

Sometimes a reboot helps, sometimes not…

Could it be that this is the same problem as losing user-defined ringtones: The SD card seems not to be visible when the phone is connected via USB to a laptop.

Where and in what file system that you format your SD?

I first formatted my new SD on my PC but Android couldn’t read it, so it also wasn’t shown.
So i formatted the SD card directly on the phone (from the storage menu), now it works fine.

Every time, I mount the SD card, my phone looses the connection. At first the phone detects it, and I have complete access. After a short while, the phone looses the connection again, and I can’t see it in the storage menu. The card works fine in my old Samsung phone. I tried to reinsert it in the old phone, unmount it there, insert it in the Fairphone and then mount it. This worked, but again only in a short while. I am not sure, if this is a hardware og a software issue.

1 Like

I did have the same problem with my MicroSD card as well.
The SD Card disappears, to “mount” the SD card I have to open the case.
It happens about 5 times last week, I think that’s a bug and hopefully will be fixed with the next update.

I have my FP2 now for two weeks and the SD card is functioning most of the time (but not always).

I don’t think that it is a bug, since it seems to work fine for most people, so personally I wouldn’t count on an update that solves the issue.

My guess would rather be that there is a hardware problem. Maybe some sort of incompatibility, or maybe the cards are simply dirty. You could try to clean the contacts with alcohol or contact spray. It is also possible that the card has defects or poor quality. Worst case would be that some slots are faulty.

I seem to have the same problem.
Every now and then the sd card is simply “gone”. Tapping mount in the storage menue doesn’t help, but so far a reboot always helped.
My sd card is a brand new Samsung EVO 32GB. I used it in my Raspberry Pi for a couple days before my FP2 arrived. There it worked fine.
I formatted the card with the phone.

I had the same problem: SD card gone, I had to open the case, pull the SD card out and back in again.

The solution for me:

I put a small piece of paper between the SD card and the metal holder.
(to get more pressure on the pins)

Since then (a month ago) the SD card never was gone.

This worked for me.

Thanks for the hint. I will try that.

Unfortunately the piece of paper trick doesn’t seem to work for me, although it definitely does increase the pressure on the pins.
Since i placed the paper there, the SD card disappeared two times already.

Ever since I change the USB mode to “Charging”, the problem is gone.

Which USB mode did you use before? “Mount SD card”? This mode hides the SD to the phone when connected to a PC (the SD is used as an external hard disk). So MTP could also be a good default setting. It allows you to access your SD via PC without hiding it to the phone.

I did use “Mount SD card”, however the phone was not connected to a PC between losing the SD card.
At work I “abuse” the USB-hub of my monitor which is not connected to my PC as charger for my phone. At first I thought that might trigger the issue, but that doesn’t seem to be the case. At least not immediately/always.
I will change to MTP mode and report back.

Hi guys

I found that when the phone is charging the phone behaves in strange ways and one of them is making the SD card disappear.
It’s sorted now as I just unplug the phone.
Thanks for your replies.

I guess that’s because it’s connected via the default USB option “Mount SD card” (see my post above). Try MTP…

So far I can confirm that the SDcard issue disappears when changing the USB setting to either charge only or MTP.
It seems like there is a bug related to the mount SD card option.

3 Likes

I did experience the “disappeared MicroSD card” problem this evening after upgrading to Fairphone 2 OS 1.2.8.

The following steps did not help:

  • Reboot
  • Restart (Shutdown + Power on)
  • Reinsert MicroSD card

The following steps, however, did help:

  1. Remove MicroSD card again
  2. Clean MicroSD card pins (actually, I used my hands)
  3. Change USB mode to MTP (was: “Charging only”)
  4. Reinsert MicroSD card (afterwards)

Therefore, I suppose the solution lays in steps 2 and/or 3.

Note: I am using a Samsung microSDXC PRO 64GB (5 years guarantee + much faster than the encrypted internal memory).