English

Microphone on headset dies after a minute in on every call

I have an issue with my fairphone 2 that when I use a headset my microphone on the headset dies around a minute in on every call. I notice this because the person I’m talking to suddenly stops hearing me. I’m on my second fairphone 2 now. On my first one I experienced this periodically. I can’t say why or when it appeared but it used to go away when I installed the latest update. On my second fairphone which i received during the spring I have had this issue since it was new. There has not been any new updates yet so I have not been able to fix this problem. Can anyone please help me and tell me what could be the origin of this and how to work around it?
Thanks!

Is your headset cabled or bluetooth?
If it´s cabled I would out of the blue guess it´s an issue with the headphone jack.
Have you also tested another?
I believe you can read more useful about it here

Thanks for your reply. I use a cabled headset from Urbanista. I have tried with two different headsets an have the same experience with both. It is as if the microphone dies after a while, at the same time as my screensaver gets activated.

But the connection generally is still active?
Sounds like some task falls into the sleep mode asa the screensaver gets activated. I can only remember specifically the wifi option to put it asleep when the phone is locked. But unless you are not using any kind of voip app for phoning I don’t see any relation.
Do you mean a special screensaver or simply the phone locking whilst the screen darkens?

I assume you have third party apps installed. Are these all the same as on your first FP2?
Have you had calls before you installed & configured your second FP2?

Unfortunately using the search function will list plenty of topics about the mic not working, also after updates.

I am afraid there is no final root to the cause. Reading through some topics and trial&error seems to be the only way left.

You may start off with this step.

If there would be a hardware problem I would expect the mic to never work. But the behaviour on you is slightly different.
Does it operate for longer when keeping the phone and screen unlocked for a longer (maximum) time?

1 Like

The connection is still active. I don’t have a special screen saver, it is simply the phone locking whilst the screen darkens when I haven’t touched the screen for a while.

I have third party apps installed. Some are the same as on my first FP2 and some are new. I have Slack, Zoom and Hangouts installed among others, are those using what you call voip?

I did a test the other day. When I called a friend i noticed the mic was off from the beginning, meaning that the screen was still active (no screen saver). I unplug my headset -> pressing the button to turn on speakerphone -> pressing the button to turn off speakerphone -> NOW my friend can hear me when I speak into the mic on the phone. I then connect my headset again and my friend can still hear me and I can have a conversation with my friend for 20 minutes, even after the screensaver was activated.

My previous impression has been that it operates for longer when I’m keeping the phone and screen unlocked. I touch the screen before it turns dark to keep it active. As soon as I forget to keep the screen active my friend can’t hear me.

Yes.

It looks like a software problem. Have you tried the save mode as recommended in my previous post?

Now I have tried the Safe mode as you suggested. I plugged in my headset and called my father. When the screen went black my father couldn’t hear me anymore.

So what does that mean? Is it a FairPhone operating system/Android software issue? Should I file a bug report to FairPhone?

What about the power saving settings? Settings -> Battery -> 3-dots menu battery power optimization (or something like that). Then choose all apps and disable the optimization for the apps in question. I could imagine that your phone sends the app to sleep when it locks itself, too.

1 Like

The setting I had was “Not optimized”. When I choose “All apps” they are all in “Optimizing”. Which app do you mean I should change to “Don’t optimize” Martin?

I was thinking of the app you’re using for calling. Or are we talking about the normal phone app that comes with the phone? I have to admit that I got a little bit confused by the VoIP question.
If it is not the standard phone app, find the one you are using in the “all apps” list and change it to “don’t optimize”.

Ok, I understand, thanks! I’m using the normal phone app. I’m just questioning this since I’m using the setting “Not optimized” today. So I’m not able to change the setting without turning on optimization for all apps. Then all apps are optimized and I can turn of optimization for the Phone app. But that should be the same as what I have today, where “Not optimized” is the selected alternative. Agree?

I’ll try your suggestion anyway and update later. Thanks Martin!

I have tried to make a phone call with the specific app Phone set to “Not optimized”. The microphone still dies when my screen turns black. Any other suggestion? Is this a bug report to FairPhone or what is the way forward for me?

Seems to be time to contact support then.

I just tried it again with a very cheap cabled headset. No issues here. The only thing that came to my mind: Is the plug plugged in completely? Since you wrote you’re having this both with your original phone and the replacement while none of us here in the thread seems to have it I still see chances that it might not directly have to do anything with the phone in general.

I can’t see how it could be plug issue since it seems to be so very connected to when the screen turns black. But thanks anyway for your comment. I will file a support issue now.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.