Micro SD Card unexpectedly unmounts

Hi there,

since none of the “Micro SD card” topics fits the problem I’m experiencing, I have to create a now topic about it:
At apparently random times, the sd card (32GB SanDisk Ultra) is “unexpectedly removed”. I’ve used it since I got the FP2 (and even before with another phone) and It usually works but, when it stars the behaviour, it enters a loop of being recognized by the phone and being “unexpectedly removed” from which it’s impossible to get out. A reboot doesn’t change the behaviour, turning the phone off, waiting and turning it back doesn’t help either, and taking out the card and putting it back has no effect.

Today has been, as far as I remember, the worse time displaying this behaviour, with the notification “unexpectedly removed” appearing every minute or so (for at least 2h now).

Since this has happened with different SW Versions and the card still works (checked it out connecting it to a laptop), I wonder if it’s a hardware issue.

Anyone else experiencing this?


I’ve had a similar issue with an old phone.
But my card worked again after a simple reboot.

I used another card and that worked.

For me this sounds like having a contacting problem with the sd card socket/pins. Cleaning them may help, also clean the ones of the card too. Maybe also test another card in this issue.


Silly question, but how do I clean the card and card socket?

Having a similar problem, after the SD card worked perfectly fine for close to a year

Sorry for the delay.

Often I could read the use of some kind of caoutchouc eraser for cleaning contacts like those flat micro SD card pins or e.g. Memory latch/pci extension cards contacts.

Generally though some kind of lint free material should work aswell.

Cleaning the socket pins is quite fidelly and depens on what kind of socket there is.
Some I would not even thouch like the ones for the sim cards.

But there are socket pins which can be cleaned using soaked lint free material and a very thin/small flat screwdriver.

1 Like

Thanks Patrick! I’ll try it and see if that solves the problem

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.