Making an extension-PCB with capacitive buttons for FP2

That of course might, but must not be caused by the extension-PCB, as I experience that kind of unwanted behaviour as well with my standard FP2 with FPOS. Haven’t been able to put it down to something special, but, as it so far settles after a while, I don’t bother too much. :wink:

1 Like

Yeah sure but it would be super if it works without a problem :smiley:

Over the weekend the problem with the reboots has occured also for me …
But I found out the fix for this problem !! :slight_smile:
I manually installed Android 5.1 and it seems to work :slight_smile:

But the curious thing is, that the phone didn´t crash on 6.0 when it was charging … I really don´t get why…

@paulakreuzer maybe you want to try this :smiley:

1 Like

I think I’ll try ubuntu first. :wink:

PS: On ubports it also causes reboots…

1 Like

@paulakreuzer Hmmm that’s strange :confused:
Mine is running quite good :confused: even control trough zterminal is possible :slight_smile:

With a friend of mine I made a small APP to controle the extension !! :slight_smile:
Full controle of the LEDs is possible :slight_smile:


Nice! Is this available for download somewhere?


Not right now… But that`s the smallest problem :smiley: if some one wants to use this, the firmware on the atmega32u4 also has to be updated :smiley:

Aha. Thanks for the reports on LineageOS. I’ve been trying many things for about an hour to get anything to work on the extension port (not this, but on a breakout board to start with a mouse). Also LineageOS. Also doesn’t work.
So: confirmed this probably doesn’t work with LineageOS (20171016). Now over to another thread…


hmm strange things are happening… the extension is working just perfect until the phone runs out of battery… when it`s charged up again it keeps rebooting frequently …

I made a small acrylic-showcase for my PCB :slight_smile:


Now that you say it that’s exactly how it happened for me. When I first tried your extension on FP OS it worked perfectly, but the phone was low on battery, so I had to charge it. Since than it constantly reboots when your extension touches the extension port.


I have absolut no clue why :smiley: but this problem seems to occur on all systems I have tested until now… But the good thing is I´m now sure it`s no hardware problem !!

This is the link where you can buy a DIY kit of the board: :slight_smile:

And here is a small blog entry from Aisler:


Here is the first version of my documentation/paper/script of the work for JugendForscht :slight_smile:
(but only in german…)



This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.