Magisk root after update to Android 13?

Does anybody know whether Magisk root will still work on FP4 after an update to Android 13? Preferable via installation to inactive slot.

If anyone else wants to try this: Don’t. Bricked my FP4…
And I can’t even flash the stock rom (from “Build manifest not found. Please inform package provider.”

Mine is working. But I used regular installation, meaning I booted with the patched boot.img and installed directly then.

Yeah, after flashing the stock image (first, it seemed like something went wrong with unzipping, then I had to “fastboot flashing unlock_critical”, then it finally worked) patching boot.img, fastboot boot, and direct install worked for me as well.
Wonder what went wrong. After all, patching the inactive slot should’ve done basically the same thing…

For me the installation to the inactive slot never worked, neither with A11, A12 or A13.
So I regularly re-root my FP4 by creating and patching a boot.img.

Oh, strange. Wonder what’s been different. I even did the update from A11 to A12 that way. Restore image, update without reboot, install to inactive slot, reboot, and everything worked as before. Just this time I wasn’t that lucky…

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.