Magisk + Fairphone OS

I have installed the current fairphone OS 8901-4.A.0021.0.
I wanted to install magisk. So this is what I did:

.\fastboot.exe boot .\twrp-3.7.0_9-0-FP3.img
# inside twrp I "swipe to allow modification"
# inside twrp I start ADB sideload
 .\adb.exe sideload .\

It then fails with Cannot mount /system

What am I missing?
I also have enabled USB debugging.

Guess the steps are the same, so maybe some hints can be found here

1 Like

Thanks @yvmuell but for that solution I would need to have access to the image file of the current stable release. Because the solution that you suggest tells me to extract the boot.img and patch that file. But I have no access to the image of the current stable release. Thanks anyway :slight_smile:

Yes but thats the way it works according to my understanding not sure how you are trying to achieve rooting with magisk? Seems to be the old way maybe that does not work any longer? And should you not be able to extract the boot.img from latest stable?

1 Like

Do you know where the latest stable can be found? I mean I have it currently running on my FP3 but I don’t know how to extract the boot partition.

What is the new way of rooting? I only know the magisk way. And it worked before my OTA update pretty well. I’ve used FP3-8901.4.A.0019.2 -gms-53c17a08-user-fastbootimage flashed it. Then I’ve fastbooted into twrp. Sideloaded magisk and everything went well. Magisk worked fine. The install of magisk fails this time.

To my understanding (never did it) the “new way” is using the patched boot.img. I assume you might be able to extract it from here? seems FP only publishes it for the FP4… Else wait if someone has better ideas :wink:

1 Like

OTA updates should be done this way to preserve root:

Thanks @Volker but that would mean I need to start from scratch. Do you know how to install magisk to my current Fairphone OS (8901-4.A.0021.0)? It fails with cannot mount /system. And I don’t know why. I’ve also tried .\adb shell mount /system_root

You might start with the older version (which is available as offline version), root it again and follow the official OTA guide I’ve linked above…
Still, I wouldn’t try this without a thorough backup of relevant data…

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.