Mageia Linux: no fastboot command possible

Hello everyone,

I was trying to follow the guide on how to install the open OS on my newly bought phone, but even after extensive searching and several attempts, I still can’t get past one key issue:

On Mageia Linux, which I’m using, the “fastboot” command not only is not installed, but isn’t even available. Installing the android-tools instead gives you “fastboot-android”, which in theory seems to have the same functionality, however it obviously makes the script that is needed to flash the phone not work, and attempting to run it in the terminal gives you “ERROR: The ‘fastboot’ command is not available.”

Things I have tried:

  1. replace every instance of “fastboot” with “fastboot-android”. Didn’t seem to work and just gives me the same message that the necessary command was not found.

  2. copy the zip unto the phone directly and attempt to open it from there. Doesn’t work and just brings up the updater that wants to download the most recent version of the regular OS.

  3. attempt to use “fastboot-android” to install the zip on the phone. Doesn’t work either and gives me the error message “error: update package has no android-info.txt or android-product.txt”

At this point I don’t know what to do. Should I try it with a different distribution, or from a Windows computer?

Thanks in advance, and have a nice day

You don’t need to use fastboot. You can just:

  • Download the right file (the OTA switcher)
  • Put it on your phone (best: SD card)
  • boot to #dic:recoverymode
  • and install the file from there

If I remember correctly you can even open the file with the updater app and install it from there, so you don’t even have to go through recovery mode.

PS: If you plan on doing further modifications to your phone (OpenGAPPS, microg, Xposed, F-Droid privileged extension, …) you can do all that via recovery too, but the more you modify the higher are your chances that you’ll one day need fastboot to fix things that went wrong. So it’s definitely a good idea to try and make fastboot work on your computer.


Hi @jute,

android-tools seem to be a good approach. You may either look with your package browser what is inside android-tools or you can locate fastboot (and maybe result in something like /usr/bin/fastboot-android). Fastboot is only working while the phone is in bootloader mode but not when the phone is normally started and you see the usual app screen. And phone should be connected via USB to the computer.

1 Like

Thanks for your help!

I managed to put the switcher zip file on the SD card and boot into recovery mode, however it will unfortunately not complete the installation process and instead aborts it with the error message “failed to verify whole-file signature”.

Attempting to install the OS with the updater also does not work, as the option “Update” does not respond to tapping, only “Cancel” does. I have no idea why.


I did get the phone into the fastboot mode, the problem was that running the script just didn’t work on my computer. Should I try to rewrite parts of it with a new path?

It seems that Mageia doesn’t have Android tools in its package database. You could try to download the android-tools.rpm from the Fedora package database and install it locally with DNF. This should work most of the time.

1 Like

@stephanK I actually do have some sort of android tools installed, but as said, the command “fastboot” is called “fastboot-android” in those, which breaks the script

I’ll try the one in the link, though. Thanks.

Instead of modifying the script I would just create a link like

 ln -s /usr/bin/fastboot-android /usr/bin/fastboot

You can use

which fastboot-android

to find out where fastboot-android is located on your system.


I assume, the binary is called fastboot-android to avoid a conflict with Google’s binary fastboot to be found on in Android Studio (at least with earlier versions). But I believe they both behave same (fastboot is open source), but they may come in different versions.

Thank you for your answers, I appreciate the help. I tried doing it from a live session of Devuan (Debian fork) and it worked there with no problems after installing fastboot there and redownloading the zip.

I will keep your advice in mind the next time I need to use fastboot, not having to boot into a different (slower) system would certainly be preferable.

1 Like

Don’t you have an old laptop you don’t use anymore? Install LinuxMint as OS and fastboot can then be installed via synaptic, and everything works fine afterwards with installing FPopenOS.

Nice option, but it’s preferably not to touch the OS files tree, IMO. I’d prefer a user directory for that. For example, some distros like Ubuntu* have a bin directory in the home directory (i.e. a ~/bin directory) added to the PATH by default.
I don’t want to explain how to set that right know, but if someone want to do that, PM me and I’ll edit this and make a little walkthrough.

However, as a quick option, a function fastboot can be created in the terminal as an alias for the real android_fastboot executable, and exported so any subsequent script could use it — until you close the terminal:

fastboot() {
  android_fastboot @#
export -f fastboot

Maybe this solves that for you, @jute, :slight_smile:

*= I use Debian, but as I has an overconfigured .bashrc, I don’t know if that behaviour is included as well by default, :man_shrugging:

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.