LTE not working?

Hallo community, it’s a week that I successfully use my FP2 but I’m not able to have a LTE connnection working. These are my settings:

  • Only one active sim.

  • Mobile data on (Settings/data usage)

  • Preferred network mode: 4G (preferred)/3G/2G (Settings/More/Mobile networks/Preferred network type)

  • Access point names: APN of my carrier selected (Settings/More/Mobile networks/access point names)

  • Connection parameters inside APN form are ok

  • The sim is 4G and my carrier allows 4G connection

  • I tried to use a 4G sim that works on another smartphone, but no way

Did I have forgotten something before thinking about a failure? This evening I’ll try to disassemble the phone.

How old is your SIM card?

Are 3G and 2G working? Are you sure there is a stable 4G connection available at the moment and at the place where you are?

I bought my sim card one or two years ago I think (I don’t remember well, but not recently) but 4G is clearly written on my sim, besides my carrier confirmed it.

3G and 2G are working correctly as H+ anyway.
I tried another sim inside FP2 in the same place where the other smartphone was using 4G even if the place where I was hasn’t a truly stable 4G connection, but I work in a 4G stable connection place and I can see only 3G and H+.

H+ is 3,75G.
It could be that your SIM is to old.
But you could try to delete all your settings of the network and setup the network again.
Perhaps that will do the trick.
If the provider has a shop nearby, go to them and test there a 4G SIM.

Hi Lidwien. I erased old profile and I created a new one; I also tried to change some APN Type parameters but LTE is still not working.

I’ve gone to a shop but they have not tested it, they only told me that my sim is enabled to 4G. I’ve a lack of ideas so I try to contact support…:sunglasses:

So it still could be that your SIM-card is to old. What is your provider asking for sending a new SIM-card?
Which provider you have?

I’m not sure but could be. When I tried my wife’s sim card I noticed that her Samsung was working in LTE band, I picked up the sim card and I’ve inserted it in my FP2 and…nothing.
I’ll try again for a longer time.

Which provider you have?


This evening I switched my sim card and my wife’s one that works under lte…my sim in her phone works in 3G but also her sim in my phone works only in 3G. Before the switch with the two phones one close to the other I saw her phone 4G and my FP 3G.

Just to post the end of the story that can be useful for someone else.
After a while the support contacted me and solved my issue or better my issues beacause were two problems.

  1. Fp2 issue. Even with a working 4G sim card in my FP2 it doesn’work, so the support suggested to register again the sim card on the network
    Go to Settings > More > Mobile Networks > Network Operators
    This is set to Choose Automatically, though if you refresh the list you get to see all available operators. It can take a while before it shows all operators. But when you are here choose the one that is from your network provider.
    After doing that my phone begun to work on LTE band with my wife’s sim card. :sunglasses:
  2. I call my carrer help desk and after a while they enabled my sim to 4G even it was already enabled…but it worked :relaxed:

Same case - but other way round.

I proved LTE-mode (4G) a short time after receiving the FP2. Worked. Now I pepare for vacation and tried mobile data again, worked, but not 4G. I have another Lollipop-phone which is able to connect to 4G. Test-location: my homes garden where 4G is good reachable. SIM-provider: for both SIM the same at E-plus/O2, both cards new.
SIM-1 in FP2: only 3G, SIM-2 in other phone: 4G
Sim-2 in FP2: only 3G, SIM-1 in other phone: 4G

FP2 has two updates, runs on 1.3.2. On both phones the preferred network-mode is 4G, both APN are identical.

Supplement: SatStat on boths phones shows the same GSM/LTE-radio-networks with the same levels.

Anyone else with similar result/problem? Any ideas?


So you’re saying you have a SIM from O2 company not from Simyo or any other MVNO? My MVNO is not LTE-enabled, so it only shows H+ if used.
I started using Deutsche Telekom SIM in slot #2 a while after using FP2, and it works nicely in 4G.

What do you want to say with your post?

I want to find out why you don’t get LTE while for me it’s working.

Today I had time to play a little bit.

I did a LTE-speedtest with my laptop connected to my FP2 via Wifi. Downstream: 33MBit, Upstream: 10MBit. That should be LTE = 4G - Speed and not 3G. And a friend of mine showed me the “settings/about phone/status”-item where he had several more items than FP2. But I found those under “subs” and there - surprise - was to read: “type of mobile net: LTE”. The same time my statusline showed: “3G”. Could it be a type-error in a language-file?

I have HSPA here for SIM1 and “H” in statusline, or EDGE here for SIM1 and “E” in statusline, or when I switch to SIM2 becoming data master with LTE enabled then I find LTE here for SIM2 and “4G” in statusline. Maybe some coding issue on the SIM resulting in indeed sort of translation error?

It was a setting in Gravity box: statusbar tweaks/signal cluster settings/LTE indicator style was set to “LTE”. To show “LTE” seems not possible within status bar, so it stayed at 3G. With this item set to “System default” everything is OK.