Lots of issues I've been dealing with for a long while now. Wanna know how to fix them

I’ve had my Fairphone since December 2019 and had a lot of issues with it and don’t recommend this phone to anyone. I’d like to find out why these things happen that make me genuinely dislike this phone*.

In the early months I had several ghost inputs which stopped 1-2 years ago.
What I still have every now and then is:

  1. When I type something on e.g. Discord the keyboard stops responding and maybe the haptic feedback vibration freaks out a bit for a second or two and then either nothing happens or all the letters I typed while it stopped responding appear in the input in a big rush.

  2. When I delete a letter or two to fix a type the delete key gets stuck and I see all my text disappear in front of my eyes. Locking the phone helps me to save as much as possible, frantically typing isn’t always a reliable way to avoid losing my text.

  3. When charging the phone typing is very sluggish and amplifies the previous issues.

  4. Switching between apps often times means losing whatever progress I did either app. Maybe I’m writing a reply to someone and need to switch to Firefox or another app to get a link or a quote and when I come back the app acts like it launches for the first time and all the text I wrote is gone. My workaround is to always copy whatever I wrote in my clipboard. This isn’t working though when I logged into e.g. PayPal in Firefox or a webview window during a “login with [Google/Twitter/whatever]” process and need to switch to a 2FA app to get my authentication code. When I switch back sometimes the app forgot what I attempted to do and I need to redo the process, ideally before the 2FA codes have reset. This issue seems to be a RAM issue I think? At least that’s what it feels like. When I restart the phone it’s usually fine again for a while.

  5. Funny enough this literally just happened again: Sometimes when I try to swipe down to get to the notifications instead of registering a swipe a button gets pressed. That’s especially annoying because now I just tried calling a group of people. This happens quite often and it’s annoying to have to explain that my phone bugged out over and over again.

  6. Swiping sometimes doesn’t work in a specific direction. Sometimes the phone won’t let me swipe horizontally to e.g. swipe back a page or swipe to see the sidebar of an app. Other times it won’t let me swipe vertically, so I’m stuck in an app and can’t access the home screen. In these situations I can swipe from app to app but not exit apps.

Are there any solutions to these issues? It’s exhausting having to use a phone with these issues and not finding anyone else having these issues or finding solutions that work (factory resets didn’t fix them either).

  • (Please avoid asking me why I use a phone I dislike. I paid 450€ for it, I don’t have enough money for a new phone, I generally like the whole fair aspect of the phone and the headphone jack and the lack of facial ID. The issues started way after the 14 days return window. Questions like these aren’t helpful in solving these issues.)


All sounds a bit of a struggle, and although I have no problems I too wouldn’t recomend any phone, but . . .

  • Have you tried using it in Safe Mode for a day or two
  • Do you have an SD card installed and formatted to expand the internal memory
  • And of course a factory reset may help

OK What OS and version are you using ?
Have you clear the cache of ‘all’ the apps ?

  • I installed and formatted an SD card to expand the internal memory the moment I got the phone. I had an iPhone SE before that and was very unhappy with the restricted storage space. Hence why I moved to Android with its SD card support.
  • Like I said, factory resets haven’t helped with this issue.
  • I’ll give Safe Mode a try.
  • I can clear the cache of individual apps but there’s no option to clear the cache of ‘all’ apps on Android 11. I do sometimes clear the cache of some apps if I’m running out of internal storage space though.

OS: Android 11
Build number: 8901.4.A.0016.6 - the one that broke the media controls in Bluetooth headphones. Software Update: 8901.4.A.0016.6 - #5 by paddykontschak

1 Like

That is most likely the problem. Try and save any personal data off the phone and reformat the SD card as portable.

I feel bad that this may have been the problem for three years :cry:

Safe mode and clearing cache . . . later :slight_smile:


Ok, I just double checked and no, it’s not actually formatted as internal storage. My bad, I should look into this before I reply. It’s just portable storage.

1 Like

Ok back to Safe mode :slight_smile:

Clearing the cache. I think you can install Accubattery which has the option to clear all.

I’m in Safe Mode and none of my apps are there. I don’t know how I’m supposed to test the issues I have in a mode without any apps.

Coming back from Safe Mode, all my widgets are messed up… Great… now I gotta fix this before I can get back to actually solving my initial issues…

Have you ever dismantled the phone and cleaned the contacts with isopropyl alcohol?

The idea is to run for a while to see if the other issues are resolved.

I see. I’m just not seeing how I can reproduce these issues without apps, much less use a phone with just the stock apps on it.

Well if you can’t produce it without apps then the apps are questionable.

So once you have any SD card formatted as portable and SIM working fine then re-enable the widgets. The apps don’t get deleted just any widgets need reseting.

if you do it one by one day by day you may find a single app that helps to focus on the issue.

1 Like

I don’t know if I can reproduce the issues because the workflow I explained aren’t things I can reproduce with the stock apps, I think.

How can I enabled apps in Safe Mode to check which app is at fault? I didn’t see any options in this mode.

And my widgets got completely messed up, so I’m not keen on going to Safe Mode again to have to reset the widgets again.

Though I am not exactly technically savvy and might be totally wrong, just my impression.

I feel reminded of the behaviour of my computer, when I am trying to do more, than it’s capable of. So it seems, your pattern of use is more, than the FP3 can handle SOC and storage wise. Too many open apps, to much stuff in the storage or the like.

So it might be an idea to check for apps that use up lots of power/storage and maybe uninstall ones you don’t really need.
You could also start by disabeling all the apps and starting to enable them one at a time to find out if there is one, that might be the root cause for this trouble.
My subconscious reminds me, that there might be some social-media app, that is especially bad for the phone performance. If my memory serves me right, faceb.xx.k was a culprit once. I don’t know, if they solved this issue or not.

1 Like

I don’t use Facebook and regularly keep apps closed with exception of the apps that I’m actively using (Discord, Spotify or Pocket Cast or YouTube, Imgur, some other apps).

I’ll give disabling apps in normal mode a try.

Regarding the whole trying to do more than it’s capable of idea, could be true, but my iPhone SE never had an issue with apps launching anew when I switched back to it, nor the whole keyboard being unresponsive or locking my delete key. It just seems weird to me that an Android from 2019 has all these issues. :frowning:

1 Like

I too wonder if you might have a RAM issue, as you suggest in your first post. Is there a way to run a self-check or diagnostic to report the amount of RAM it thinks it has, and/or check its operation?

Could you try using different chargers and cables? I had this issue with one of my previous Fairphones as they seemed to be quite picky about the voltage being provided.

With regard to the touch issues of recommend contacting Fairphone support as it may be a warranty issue where there is problem with the screen and replacing it may resolve if cleaning the contacts doesn’t work.

Hi there,
some ideas to these two points, wich I sufferd too, but got rid of them:

Wich Keyboard App do you use?
Since the last update of Typewise wich I am using this got solved and I am a happy writer again.
It seems like a problem between the interface of the keyboard app and the OS.
I would suggest to try it with another keyboard app…

1 Like

I have a bunch of cables and powerbanks and whatnot and the issue happens regardless of the charger or cable.

I’m using Gboard. I’ll give Typewise a try, thank you.