Lost internet yesterday even with 4G present - any ideas?


Hi and welcome to the forum.

When you say internet do you mean via Wi-Fi, the mobile network or both.

think thats answered?

@JJTreby did you contact your SIM Provider? Messaging and calls dont need internet so how is WA partially working?

so you have issues since a longer time already?

could you confirm the exact build number as up to date might differ depending on when an update is available on each device?

sorry, not wifi, mobile network, although I could still message and make phone calls. Browser says ‘no internet connection’ but phone says ‘4G’.

Issues only since yesterday morning - accessing internet just stopped. still happening today. whatsapp seems to work ok. viewing webpages does not. accessing gmail does not.

Build number 8901.4.A.0016.6

service provider shut at weekend so emailed.

re: restarting phone. whenever an app or something has not worked I do a restart and it solves the issue. For this issue it has not solved it.

WA seems to work ok, means you can send a WA mesage when Wifi is not connected?

Such a sudden interruption to me sounds a bit more like a reception issue, unless it occurred directly after a system update (version you have installed if very new…).

However, have you tried the other SIM slot? Have you checked your APN have not changed, i.e. check if entered as indicated on the network providers HP. Maybe try to reset the APN to default (three dots in the APN settings), just make a screenshots of the current entries. Can you test another SIM card (better different provider)? before this update there was a bug for some user which could be solved by adding a second SIM and then it was possible to change the mobile preference from always ask to the preffered SIM…

1 Like

Thank you for all your help - no luck yet!

I will try the different sim slot next. There was a recent update and this may have been the first time since then that I have tried away from wifi.

I am not sure what the APN is or how to reset (searching phone does not show it either).

The only screenshot I have is this: (not internet, 4G working):

APN can be found under settings-network-the SIM card network-enlarge “additional” at the bottom

1 Like

found the APN and reset - not sure why it does not come up in search.
tried 2 sims but i do not have an option to just select one of them. tried all combinations but still have the same issue.

i think i found the preference for 2 sims in the google settings. same issue still.

Can you enter (Google) or (Wikipedia) in your browser’s address bar?

Neither work on 4G. They do with wifi on.

So what is the network icon like, does it have a little cross in the bottom right indicating dta is not available either by the network or a setting on the phone. ?

Oops! I can see from an image you posted it is disconnected.

So does the phone have data enabled as in the post by Yvmuell above?

It is weird. Hopefully it is not the combination of Fairphone and Ecotalk as both companies are doing the right thing for the world - I don’t want to change either but it is the 3rd issue within a year.

So just to ensure we talk about the same setting

This is what I meant

So beside the setting, could you get mobile data with the other SIM and was it from a different provider?

no data from other SIM - same provider though.

Did you check these settings: https://www.ecotalk.co.uk/help/getting-started/apn-settings

1 Like

Yes, all identical to my phone.

1 Like

In your screenshot

  • 4G means 4G is available on the cellular network connection.
  • The triangle indicates signal strength (pretty low in this case).
  • The little cross in the triangle usually means that the mobile data connection is switched off or unavailable, but in that case normally you wouldn’t see “4G” mentioned. Seeing the two together is strange and I don’t remember ever having seen that.
    I would interpret that as meaning “4G is available on the cell but signal too weak for a data connection” but that’s just guesswork.

Tomorrow when you contact ecotalk support, make sure you describe these symbols exactly – and that they understand.

You might go to the following setting:
Settings > Network and Internet > Mobile network > Advanced > Preferred network type,
and instead of Automatic (4G/3G/2G) which is the normal value for this setting, test the other options.in descending order.

1 Like

Thank you - all tried and still same, no internet via:
google calendar

but can still use: