English

Looking for a stable lineage OS

That’s good to read. :slight_smile:

I agree, but I’m not making demands, I’m just giving feedback based on what Murphy’s Law did to me the 1st time I got around to trying one of their builds. :slight_smile:

Then there was a misunderstanding. You see, further above I was saying that it’d be better to have occasional stable releases and you quoted it and responded to that by telling my about LineageOS for microG. Since you said that it’s awesome I naturally assumed that it’s awesomeness had something to do with it being more stable.
But thanks for checking out whether or not the new version boots. It’ll be super helpful to know in advance whether or not I can use it at all.

And if that law becomes Sacrebleu’s law, then the French are SO going to hate me for adding popularity to a word only used by fictional cliché french characters. :smirk:

Thanks. And yeah, I suspected that, but after that ordeal I felt like giving feedback in addition to asking for help, and since I tried to combine lineage and FP2 I thought that either community would be fine.

@AnotherElk
I just now tried to install lineage OS with microG, I downloaded the oldest version 20180808 and twrp gave me error 7, so that one isn’t compatible either. I am having the worst luck right now. Which one do you have installed?

Error 7 should have nothing to do with the build.
Sounds rather like you didn’t wipe your previous OS or perhaps didn’t install a halfway current TWRP …

https://lineage.microg.org/ says “This ROM has few changes from the official LineageOS ROM, so you can follow the installation guide for your device on the LineageOS wiki.” … which would amount to this guide here …

https://wiki.lineageos.org/devices/FP2/install

Just follow the guide and use lineage-16.0-20190819-microG-FP2.zip (currently) with it instead of the regular LineageOS file.

20180808 is the last build of LineageOS 14.1 for microG, which was Android 7.1.
20180508 is the last build of LineageOS 15.1 for microG, which was Android 8.1.
LineageOS 16.0 for microG, which is Android 9.0, is the only currently maintained version.

Especially in transition to the respective next major Android version it is useful to have the older major Android version around for testing or for going back when something perhaps doesn’t work, so it’s rather nice they keep these around … but I guess it may look confusing for somebody just starting to get into this all.

1 Like

Alright, thanks, I’ll try that.
It’s good to see that they keep old versions around in contrast to the main lineage project and it’s even better that they apparently didn’t upload a newer version, presumably due to the boot bug I guess.

I currently installed lineage from 2019-08-23 again, but before I could even try to download a play store I tried to get my bluetooth keyboard to run, but any URL I type in gets deleted again when I hit the enter key. That problem doesn’t happen with the virtual keyboard. It’s as if my enter key is mapped to a home button or something. Works fine in the calculator though.

Also you were right about the wiping thing. I thought I had wiped everything, but when I installed lineage, everything was still there and I got some Google Play Store crash-loop, so I wiped it again and formatted it for good measure.

They did (it’s automatic), I tried it, and it didn’t boot.
Apparently they have taken it offline in the meantime.

Okay, it’s nice of you that you took the time to do that.

Also I just tested my phone for the freeze bug and sadly it happens with “lineage-16.0-20190819-microG-FP2.zip” as well, i.e. I open Telegram, go into some room, post a bunch of gifs and after 30 seconds it freezes. But at least with lineage I can still close the App. Fairphone 2 OS made me reboot the whole thing by pressing the power button for 10-15 seconds.

And I also verified that this bug does not happen with my old Yotaphone 2 (Android 4.3).

So, I guess now that I actually did everything you advised me to do, except for disassembling it, that means now is the time for contacting official support and getting the thing repaired.

On an btw: Today I received a new update for the Fairphone OS, too, and after I installed it I could no longer connect to my W-LAN. And the freeze bug was still there, too.

But thanks for all your time! You’ve been a great help!

Hi all, a month ago decided to install LOS and I succeeded ! with Micro, Magisk and all wonderful stuff, recently tried to update like every normal user, September 8 won’t boot, September 12 won’t boot and today September 13 won’t boot ad well !! Im I doing anything wrong ? I follow the instructions, download, install, automatically reboot recovery, install then stuck on LOS logo animation for 5 minutes then the phone reboot to recovery again, good that I made some backups so I can restore the OS. any ideas? I am the only one having this issue ? I would be very grateful if someone can help.
best

I’m on sep 12, which of running fine for me, but I’m not using microg. Magisk, though, yes

1 Like

LineageOS for microG, 20190908 build here. No problem (which wasn’t there before).
I’m not using Magisk, though.

LOS + microG, works great on latest update from monday 9th. Haven’t tried Magisk lately (it is annoying to reinstall it every time) but it worked a few months ago.

I can’t see the Monday 9th update in updater…

There was a 20190909 build with “userdebug” instead of “nightly” in the filename.
But there was only one place among the pages of the LineageOS website providing the link, and I can’t find it any more, perhaps it was taken offline.

The download page and the changelog never mentioned this build, so it’s probably better to forget about it :slight_smile: .

Thank you Elk, jus
1- convert microG and other adds( Nominatim,Dejavu…) to user apps and update via Link2SD
2-update Lineage OS to the latest one.
3- boot, took time to check the SD card.
3-convert MicroG to system app.
4-reboot.
5-again stuck on LOS animation logo for few minutes and automatically reboot animation logo, bootloop !
I am sure that MicroG is the reason or maybe Magisk? Is there anyway (even painful way) to update LOS with MicroG installed ? I do not want to wipe everything and start a clean install…
TWRP 3.3.1.0
or should I just stick to my OS and never update it ?
thanks

I don’t know, as I don’t use regular LineageOS.
I’m using LineageOS for microG, a fork of the regular LineageOS where microG is conveniently built-in (which the regular LineageOS project didn’t want to do) and thus isn’t any trouble with updates.

I can understand that, but ultimately you should be prepared to do it.
Both microG and Magisk (at least as far as I understand, I don’t use Magisk) are changing stock Android significantly. Stuff can break.

If you do a clean start I might suggest you have a look at LineageOS for microG.
You can’t install LineageOS for microG over an installed regular LineageOS and vice versa.

Ok ! then should I do a clean install or dirty (with migration zip)?
should I delete MicroG from LOS before doing the migration to Lineage for Microg ?

best

As you don’t want to wipe, you could try the Dirty Install first.

I’m always in favour of a clean install, though.

Can you even do that if LineageOS doesn’t boot?

Anyway, try to backup as much as you can of your important data if it isn’t backed up or synced to somewhere else already. TWRP can help with that …

Hi,
1-Restore from backup to Lineage OS.
2- delete F droid and Microg + Nominatim …
3- Recovery boot, Sideload Install zip, Linage for MicroG Migration zip followed by Lineage for MicroG zip then addonsu then Magisk zip.
4- Reboot system = bootloop again.
5- Restore to previous Linage.
A clean Install is a full-time job !!!

Done ! I did wipe cash, system, data then reboot boot loader and refresh TWRP then reboot to recovery and sideload Lineage for MicroG then addonsu then Magisk, reborn boot loader and reflash TWRP then boot, this order worked for me, otherwise I have a boot loop, did not loose the apps but few from F-Droid which is now installed as a system app, no need for Fake Gapps anymore since Lineage for MicroG has a Signature spoofing, I lost Open Camera which was installed as a system app.SO it was so called a clean install, not migration from LOS. fingers crossed everything is working well for the last 2 hours. thank you all for help.

1 Like

A small Update after restart I had a boo loop since I installed both addonsu and Magsik, I had to redo the hall thing without addonsu and it ok now.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.