Log in a captive network introducing password through web browser

Dear all,

the shared Wifi at my work requires a password through the browser similar to how it is in many airports or hotels.

This particular wifi is categorized not safe also by other devices. However on other devices I can click a link in the browser similar to ‘connect anyway’.

The fairphone leads me to a special log in page just showing a big red lock sign with no option to connect anyway. The options I get in the menu are ‘do not use this network’ or ‘use this network as is’.

When choosing ‘use this network as is’ I am not prompted to enter the password through the browser.

I will also contact our admin ‘to make our network safe’, but any other ideas on how to connect to the wifi?


That is called a “captive network” and is unsafe by design, because to bring you to the captive portal, the router hijacks your first HTTP connection (which tricks your phone to send the HTTP request and cookies to the portal instead of to the destination website).

I have no problems with captive networks. Which web browser do you use on your FP and on your other devices?

1 Like

Thanks. I was using Chrome.

The IT admin at my work sais that Chrome sometimes makes these problems.

However, we solved it like this:

1 Click on 'Sign in to network’
2 Go on the button top right choose 'use network as it’
3 Go back to the browser and it will tell you that you have no internet
4 Type any address (ie google.com), the website will forward you to a page saying its not secure
5 Click on 'advanced’
6 Click on the link about connecting to the unsecure network ( mine is called 1.1.1. or so, but Im sure you will figure that out :slight_smile: )

Step 4 is the one I didnt do last time,…



Glad you solved the issue!
Thanks for the steps too, I’m sure they will be useful for other people looking for the same problem, :slight_smile:

PD: I’ve renamed the topic for this last matter, :wink:

1 Like

Thanks a lot for this; I was getting desparate until I found this :grinning:
Oddly enough I got this error only occasionally at my work (and coincided with Mobile network problems), still don’t know why it worked some times and other times it didn’t. But at least I know now how to circumvent it.

Thanks for the input and leaving the answer here.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.