Locking bootloader after calyxos installed

Hi all

I managed to install calyxos on my fairphone 4 but i am not able to lock the bootloader. if i do so, i cant boot the phone. it says my device is corrupt. in case i leave the bootloader unlocked, everythings fine. i wonder what i do wrong? any help is much appreciated.

Did you use the installation tool for the install?

Yes absolutely. I followed the step by step manual on the calyxos website. The last step was telling me to lock the boltloader on my phone, which I did. But im not able to boot the phone then. If I ignore this last step, leaving the boltloader unlocked, everything is fine. I would really like to lock the bootloader though…

I think you’re better off asking for help at an official CalyxOS forum, like on their Reddit. Maybe the devs know what’s up.

If you updated your phone to the latest FPOS release (175) before installing CalyxOS, that could cause issues since the patch level of the factory images linked in the instructions is lower.
Try the newer 4.4.1 factory images, those should have the right patch level.

Whatever you do, don’t manually lock the bootloader!

The Matrix channel is the best place to ask for help, there’s usually someone around who knows what to do.

3 Likes

Thank you so much guys for helping me. I know its hard to deal with noobs like me, so forgive me the following question (I just really dont want to brick my phone): What do you mean with manually locking the bootloader? Im a little scared, because the last step of the manual (on the calyxos website) tells me to lock it. So if I replace the factory image i used with the one you linked me hirnsushi, should I be safe? I would follow the same steps as stated in the manual, just using the newer factory image.

I wish you all a happy new year :slight_smile:

Oh and yes, I did update to the latest FPOS - your right. Would explaine my little dificulties im facing right now becuase of the missmatch of the versions… Thank you all in advance

As long as you use the Calyx installer, which has safeguards in place that should hopefully keep you from bricking (and since you where able to unlock the bootloader again, those seem to work just fine), you should generally be safe :crossed_fingers:

It becomes dangerous if you don’t lock it at the end of the installation, boot into the system and then issue the command to lock the bootloader manually after that. Never do that.

In short, use the device flasher, and if something doesn’t work just run it again, don’t run any other commands.

Exactly :slightly_smiling_face:

1 Like

HOOOLLLYYYYY SMOOOOKES :smiley: Im so happy it worked. Thank you so much. Happy new year :slight_smile:

4 Likes

Hello,I hope I am in the right place for my problem. I followed the procedure to install CalyxOs on FP4 using the dedicated installer. After launching the installer and validating the unlocking of the bootloader twice (5 and 5.1 procedure) the phone rebooted and it doesn’t turn on anymore no matter what I do. Anyone have an idea what I can do?

Welcome to the community :wave:

When you say doesn’t turn on, do you mean the screen stays black regardless of what you are doing? :thinking:

Could you check the following please :pray:

  • When connected to a PC, do you get any output for fastboot devices?
  • What happens if you disconnect it and press Power for 10+ seconds?
  • Does anything happen if you connect it to a charger and wait for some time?
1 Like

Hello, thanks for the answer.

Yes I tried holding 10sec, 15 sec, removed battery for a day and tried again but nothing turns the screen on. The phone doesn’t seem to boot at all.

When I connect the phone to my PC and do fastboot devices there is no output whatsoever.
When I disconnect and press for +10 seconds “nothing” happens. At least nothing that I can see, no led, no vibration, black screen.
When I connect it to a charger nothing happens, I will try to leave it longer.

So after poking around for a bit I have some news and it’s not so great…

The phone is doing “something” when I hold the power button for +10 seconds so I tried to find what.
So I plugged it into the PC and without trying to turn it on I looked to see if my phone was detected. And it is as you can see:

But after some research, I found that this QUSB_BULK_CID error happens when the phone is bricked (suspected that) and the phone enter a EDL mode when I try to power it up. Now, I don’t think I can get out of this situation without sending it to Fairphone (but I’m all ears) so I would like to know how I ended up in this situation…

Usually you should be able to leave EDL mode by unplugging and holding Power + either Vol. up or Vol. down, IIRC … :thinking:

If that doesn’t work you might be dealing with some kind of hardware failure, as you already suspected :grimacing:
You might be able to collect some additional information with edl, but we are lacking the necessary loader to actually do / fix something in that mode.