Lock screen keeps changing

Hi, the lock screen keeps changing from a large digital clock with the date in small font to a white box at the top with a small email icon on the left side and a large ‘O’ and small closed envelope with + next to it on the right side.
I am then left only with the time very small right up at the top with sim and battery status.
It changes back and forth for no reason (I haven’t done anything to the phone).
I saw on a similar post (which is now closed) about putting the clock back on the lock screen, where it was advised to select the digital clock widget. I’ve tried that and it immediately changes the screen to what I want but it doesn’t lock it for future times, ie. when I next get the lock screen it’s back to the white box etc.
Any suggestions?

You can have multiple lock screen. I think you added a new one, but the old one (sounds like the Dash Clock Widget) stays as the default one. The default one is the one left from the camera.

You can delete a lock screen by pressing it and holding the thumb until “X Remove” appears. Drag it on top of this new button. Here is a screen shot:

Hi, thanks for responding! I have tried in the past pressing on the screen (in desperation not because I thought a X Remove would appear), I tried it again and it still doesn’t appear…

The top picture shows the screen I don’t like, which keeps replacing the screen shown in the bottom picture (which I do like). Whichever of these happens to be the current lock screen appears immediately to the left of the camera. Whenever the top-pictured screen is the default one, the bottom-pictured one is to its left, but the padlock is right at the bottom of the screen. If I push the padlock up with my finger it will show text messages that may have come in (which aren’t visible with the padlock at the bottom of the screen)
Any suggestions for getting the solid lock screen with digital clock back?

Yes. Press and hold the widget. Don’t release your finger before you have dragged the widget to the remove button.

Sorry but which widget? I’ve pressed all over the screen, including all over inside the white box. When I press anywhere along the top of it where it’s shaded all that happens is that when I let go finally because nothing is happening, the white box becomes smaller. When I press anywhere else inside the white box or elsewhere on the screen nothing at all happens.

I just found our that some widgets need to be expanded (the padlock needs to be at the bottom rather than I’m the center of the screen) before you can drag them away:

You can achieve this by swiping down on your screen.

Thanks, it worked! Cheers!