English

Living without Google 2.0 - A Google free FP2

Thanks @georgmayer, that’s an essential hint. Works much better. Sure I enabled the Online Maps.
It’s somehow strange to do it that way, but you already mentioned the somehow strange user interface :wink:
This also somehow reduces the Ausgangspunkt (point of origin?) setting to absurdity, as it’s only used to show the distance from that point to the results.

But nonetheles, better than feeding Google :laughing:

2 Likes

Hello Fairphoners, hello paulakreuzer,

this is my first post in the forum after I’ve got my new FP2 at the end of Dezember. First backer :slightly_smiling:

One question: Disabling of ‘google play services’ app not possible:

At the very first and without sim card inside I disabled the most google apps like paulakreuzer recommended above. Only maps, contacs and google play services were still running. After testing and playing around with my new phone I insert my sim-card yerderday. (I have no google account!)

Now I would like to disable the ‘google play services’ app, but it is not possible anymore!? The disable-button in “app info” is greyed out! What can I do now? Something what I have to do before?

Thanks for your help.
Mirko

May be it helps…
How to disable Google Play Service

How to disable Googleplay Service (VDO)

2 Likes

Google Play Services and Location Services can’t be disabled by default and I guess Apps that can disable it will need root privileges.

ok. Thanks @nohwann.

But strange, after reboot and searching in the settings again now I can disable the app in settings–>apps!?!

@paulakreuzer:
I don’t want to root my phone. Now the button ‘Disable’ is not greyed out anymore and it is possible to disable the default app Google Play services’ in settings–>apps.

I am confused. I understood that Google Services can’t be disabled (is still running under apps->running). Or is Google play services the same like Google services?

Shall I disable google play services now or will I get some problems with the system?
It seems that Google play services is responsible for a lot backround data (settings->data usage). And I don’t like that there is something going on without control.

1 Like

Its really strange. Suddenly I can disable Google Play Services too. So I did, I’ll post back if I run into any troubles.

PS: So far I didn’t run into any problems with GPlay Services disabled. This leaves Location Services to be the only one that can’t be deactivated without root. However on FP osos you can replace it with µg Unified Nlp.

Did you made anything which provoked this?
What else google services did you disable already without problems?

I have no idea what changed except the date. :wink:
If anybody finds out please edit the first post ( :pencil2: wiki).

I disabled all other GAPPS&Services.

I think once you have disabled everything that uses Google Play Services (and maybe reboot?), then you can also disable them? Anyway, here is everything that I turned off:


Update: Additionally I deactivated the “Pictures” app which seems to be part of Google+ and the Calendar which also connects to Play Services. To replace them I copied the “Gallery” app from another phone (see here) and as a calendar I now use Etar.

1 Like

I’m pretty sure I tried after disabling the other GAPPS and after a reboot, but it still didn’t work until yesterday.

I disabled the same apps that @m4lvin did. What about the “Photos”-App? I thought it’s an GAPP as well. If so, do you know any nice alternatives? - Thanks!

Unfortunately there is no working gallery app in F-Droid.

As @paulakreuzer said there is no good gallery on F-Droid, but now I managed to copy the standard “Gallery” app from a Nexus 4 with cyanogenmod to my FP2 and it works well. Two ways to get apps from other devices are APKShare and the Swap Apps feature of F-Droid.

2 Likes

:fr:
Bonjour,
Merci pour ces explications techniques, qui semblent être exactement ce que je recherche.
Mais c’est très technique et mon pauvre anglais n’est pas suffisant pour comprendre exactement tout ce qui y est indiqué.
Pourriez-vous donc rédiger ce post en français, et dans un langage technique accessible à la non-experte en informatique que je suis ?
Merci d’avance !

Hey,
Thank U for this post, but it’s very technical and my poor english is not enagh for understandig exactly all. :confused:
Then could U please give me (and us) the same explanations in french, and in a technical langage I could unterstand ? I’m not an informatic expert, sorry !
Than U

:fr: Resalut Mimi,

ça reste un forum de la communauté. Même si les gens veulent bien aider, personne n’aura le temps de traduire tout un fil… Si tu vois quelque chose d’important (là je parle de un ou deux posts), tu pourras toujours demander mais un fil de plus de 100 posts…

Courage

:gb: Just pointing out the fact that this is a community forum and that nobody will have the time to translate a whole thread of more than 100 posts…

But somebody could add a translation to the first post, or more than one. It’s a wiki. :slightly_smiling:

I’ll have a look at it later but right now, I unfortunately do not have the time.

2 Likes

Hi, I want to life without google, so I deleted or deactivated the most Google programms.
With this also the Google Camera. But as a result I can’t use the camera button. And the display say me that the “ProgrammableButton” was ended. I’d like to assign a new camera programm to the button. But I don’t now how and where I can find this into the settings.
Maybe some of you might know what I mean.
Thank you in advance!!

For me it was enough to disable google camera, install a different camera app (open camera) and after starting the app the first time pressing the programmable button opened open camera.

What camera apps did you install?

I’m not sure whether I understand your problem correctly, but you may just need to install a camera app.

Edit: @paulakreuzer was faster and probably more helpful. :wink: