Listening to AAC+ radio

I downloaded RadioDroid from F-Droid. It works fine with MP3 radio stations but cannot play stations that are described as AAC+. I am particularly interested in Radio Vostok ( but have tested two more AAC+ stations, that didn’t work either. Do you think I need an extra app to allow playback? I asked on the App’s Github page; users with other Android-driven phones don’t have the same problem.

If someone can recommend another web radio player, that might be a solution, too.

Try it with VLC. It is able to play many formats, but I personally haven’t tried AAC+ radio stations with VLC.

Just gave it a try:
Running Fairphone OS 17.11.2
Installed RadioDroid
Played some Radio Stations (MP3 as well as AAC+) and everything went fine.

So it’s not the combination of player, OS and phone, that’s causing the problem.
Haven’t found anything in the phone settings, either.
Could it be due to the network provider or contract?

Just tried it out - seems to work. Apparently, VLC can play this format while the standard Android player can’t. Thank you!

1 Like

Installing VLC did the job. I’m running 17.11.2, too. You must have some other app installed that made it work, I guess…

Yeah, you were right of course, I am running the standard (Google) Fairphone OS. Missed to check the category. (In reply to your withdrawn post!)
So it seems to be a bug of FP Open.
I can’t think of another app I am using that could make it work.
Just great, that VLC works for you.
Btw. what version are you running and where did you get it? Asking because of this thread:

1 Like

I tried to download it here: and was redirected to google, so I got it via Yalp. It’s version 2.5.12; in the description, it says it doesn’t depend on anything (in other words, no GSF needed).

1 Like

Thx for the info. I guess I will “update” my VLC-player via Yalp then too, as I am stuck with version 2.1.20, the last one, that was available on F-Droid, before it became unavailable.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.