LineageOS 14.1 with OTA updates for FP2

yaaay, I am not alone!!!

1 Like

I’m trying to install LineageOS. But I did not understand your manual… :confused:

I’m coming from FP OS, I installed the TWRP-App, started it, gave root acces, made a backup - and now? I downloaded the img file for fairphone 2. How can I “boot into twrp”? And how can I do the factory reset? How I can queue a lineage build? I don’t understand nothing…

Perhaps there’s somebody out there who can explain it in german?


I guess everyone wants to upgrade ASAP due to recently found flaw in WPA2.

I’ve done some tests with two different phones and it seems LineageOS is friendly on the battery. How would you describe the battery holds out compared to the official firmware?

1 Like

Hi all,

I’m fed up with all the sponteneous restarts and thinking about giving Lineage OS a try. How does it work for you guys? Is it more stable?

Those are probably due to your battery not sitting firm. Check the forums around for a solution on it. I seen a post where someone used a piece of paper/cardboard to get it fixed.

Ok, you installed the App? Did you follow the instructions from the Website?

Install the app and open it. Agree to the Terms. Select TWRP Flash. Select your device from the device list (fp2) and choose a version. The file will download to your Downloads folder. Browse to and select the file. Tap on Flash to Recovery.

Than switch off your device. Switch it on again by holding the power button + volume up buttom at the same time. You should boot now into TWRP.

Than follow these two guides:


I don’t know. I know over 6 people with a FP2 and the all have the same problem. I think there are memory issues. Device starts to slow down. Random apps crash ("{app name} stopped working") and finally the phone restarts.

But I’ll take a look.

I found the downloaded file (not in download but one folder above). When I tap it, I can’t tap “Flash”. I have to choose between “open with”, “open as”, “link on the desktop” or “edit file”.

What can I do now?


EDIT: Sorry, I think, I got it now…

1 Like

I got it! I flashed LineageOS and GApps. Then I rebooted the phone. I logged in the WIFI and now it’s seaching for updates… How long will this search be? I’m waiting for >15min now!

After all the system started…

But there’s no root access?! How I can get it?

Thanks for all,

Settings - About phone - tap on Build number several times in short succession until a popup says that you are developer now.
Then go back to the Settings menu - Developer options - Root access - choose Apps, ADB or Apps and ADB.

Many thanks! Now I’m happy again!

Thanks to all and sorry for my many postings and for my bad english!


I think the image of the TWRP is incorrect (on your fileserver). It is only 7kb. It should be around 10MB. Can you upload the correct one?

Thanks, indeed it was a wrong download. I’ve removed the twrp files from the buildserver as the instructions and downloads are also hosted on the TWRP official pages.


Can you test the latest It should contain the fixes for WPA2. You can flash it through OTA.

What I need tested is:

  • Update goes flawlessly
  • SIM functionality works (calls/data)
  • Updater works
  • WPA2 is fixed (is there a app to test if it’s still vulnerable?)
  • Root is available
  • Device info should 16-10 build date

I am on holiday, so I can’t test it all right now. But if 2 poeple say these tests are okay, I’ll push this testbuild OTA.


Did the Update through TWRP (don’t know how use the OTA updater with a manually downloaded zip file)

  • Updating went well for me.
  • Mobile Data works. Didn’t do a phone call yet, but tried USSD, which worked.
  • root is available, works.
  • Build date is October 16th.



Pushed new update with stamp 20171016 with all the WPA fixes:

Thanks for testing @struppi


Thanks for doing the real work, @snevas :slight_smile:


I’ve just recieved my Fairphone and flashed the 20171016 build (also tried Thanks for the great work!

However, I can’t shut down my device - it just boots again immediately, as if I had selected “Reboot”. An adb logcat doesn’t show anything interesting, but it also quits after the shutdown.

Any idea what could be going on there?

Yeah, this bug is still around …

But you can reboot to recovery and power off in TWRP, that works :wink: .

1 Like