Lineage OS -Signature verification failed

Hi all,
I’m trying to install Lineage OS on my FP2, with no success so far. I always get: ‘zip signature verification failed’.
I used the instruction from Lineage OS site, flashed twrp, tried to sideload the lineadge zip file.
This is what I’ve done so far.
-Checked the zip file manually, as described on the Lineage site. It should be fine.
-In twrp I turned zip verification off (it is off by default, but i tried to toggle in on and off again)
-Used different twrp versions (3.2.3, 3.2.2 and 3.2.1)
-Used different lineage version (all of them, which are listed on the site)
-Downloaded the lineage zip file on the phone and tried to install it in twrp.

I’m currently running out of ideas.
I noticed one difference with the lineage instruction
Step 7: Select the Cache and System partitions to be wiped and then Swipe to Wipe .
During this step there is no System partition that I can select. But I’m not sure it means something.
Has anybody an idea?


Are you sure? Your problem sounds like installing those new TWRP versions was not successful.

Mind step 6 of the installation guide right after flashing the new TWRP version:

"Now reboot into recovery to verify the installation:
* With the device powered off, hold Volume Up + Power. Release when boot logo appears."

This is really important. If you boot an OS directly after flashing TWRP (even undeliberately, it happens), the OS will probably restore its own recovery.

If this somehow doesn’t work for you, you can boot a signed TWRP image (this is not the normal TWRP image you downloaded so far) with fastboot to force using the latest TWRP version. For details see #twrpwoflashing.


Oh dear. I missed the pretty large version number at the top in twrp. Indeed I did something wrong with the installation of twrp. Thanx for the help!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.