Lineage OS 14.1: ownCloud client not connecting anymore

After I have installed Lineage OS on my FP2 from scratch I cannot use the official Android ownCloud client anymore. When it tries to connect to my server I get an “unknown error”. It used to work fine under FPOpen. Has anybody experienced similar problems or has a possible workaround ?

NextCloud app here works just fine with an own server running NextCloud.

If you own the server, I’d suggest to migrate to NextCloud. I did and it was pretty straightforward.
If you are stuck with ownCloud, wait some minutes and I’ll test the ownCloud app in an expected-to-be-quick deploy.

Edit: ok, my test worked fine… I tested ownCloud stable and beta clients from F-Droid. Did you use HTTPS? The URL must not contain anything apart of http[s]://[subdomain.]domain.tld/[subpath/]

Thanks for the advice and testing.
Are there any advantages of NextCloud over ownCloud ? The server is my own, so I can update / migrate at any time.
I just did an adb - logcat and it looks as if the app is not handling the SSL certificate properly. The server certificate uses cacert as root ca and I have installed the cacert root certificate on the FP2. While browsers like Chrome use the installed cacert root certificate, the app does not seem to use it. Logcat is showing the following exception:
07-27 15:03:49.537 22812 23013 E GetRemoteStatusOperation: Connection check at https://server.domain/owncloud: SSL exception
07-27 15:03:49.537 22812 23013 E GetRemoteStatusOperation:

Don’t know what’s wrong with your certificates but security is one of the advantages of nextcloud in my opinion.

1 Like

Android 7 has changed the way Android handles user-added CAs. Unlike in previous versions, apps don’t trust such CAs by default. They have to explicitly opt-in to do so. Maybe (your version of) the ownCloud app doesn’t do that?

@ChuckMorris’s comment is interesting. In my opinion, that looks in fact as a SSL certificate validation issue, and the ownCloud Android client hasn’t been updated in a while.

I don’t want to change all your elections, but do you know about Let’s Encrypt? It is an automated CA that ships free SSL certificates with the aim to reduce the leaks produced by clear, insecure HTTP. Its certificates are cross-signed by other Internet infrastructure actors, so you don’t need to import other certificates. I didn’t have any problem so far with it.

@sky is right. ownCloud seems abandoned and NextCloud has knit a net around collaboration and open source. Its software has been improved in features, separation of matters (officially supported popular apps in the store, like Contacts and Calendar), security, stability and speed. It is the rebirth of the ownCloud project —its spiritual successor— in my opinion.

I can help with the upgrade if you wish. Although knowing the SLL issue, I suggest you to change first that, if you are going to do that. It would be great to report the issue to the official ownCloud Android repo, nonetheless.

Using Nextcloud with a let’s encrypt certificate on Lineage 14.1 too. Works like a charm.

1 Like

Thanks for the discussion and help! I tried the NextCloud client and had the same problem, but replacing the CaCert certificates on the server with Let’s Encrypt ones did the trick - easy enough with “certbot”.
I will migrate my server to NextCloud sooner or later, but for now I am happy to be on ownCloud again.

1 Like

This topic was automatically closed after 183 days. New replies are no longer allowed.