English

Lineage 17.1 - FP2

Does anyone have experience with AFWall+ on Lineageos17.1? My issues with the mobile data reconnection had returned but seemed to be fixed with tonights update. However when I activate AFWall+ there is the same problem again -> no reconnection.

1 Like

Maybe this is what you’re looking for


But I’ve never used it myself

1 Like

You can install Checkup from F-Droid: https://f-droid.org/fr/packages/community.fairphone.checkup/

3 Likes

OK! The app works fine, is what I was looking for actually. Thanks.

My primary microphone was not working with the FP2 OS neihter with the LOS 17.1… Nevertheless it works now… Did you fix something? I thought it was a hardware problem of the microphone module because when I removed and reseated it it worked for about two days after (then breaking again…).

It is a problem I know other people have with the FP2. If it is fixed it would be great! But I don’t know, I hope it don’t stop working as in other occasions.

Cheers.

Tried TWRP backup of encrypted LOS17.1, but TWRP is not able to decrypt file system?
(latest LOS build and latest TWRP version … tried several TWRP versions…)

Without a decent reliable full system backup/restore mean, I am reluctant to switch to LOS
The new LOS Recovery does not offer backup/restore.
Any hints or tips appreciated

TWRP on the Fairphone 2 is not able to decrypt encryption from Android 8 on.
You can try your luck with this custom build here … Custom TWRP 3.2.3 to decrypt Android 8/9 encryption.

But only the data partition is encrypted anyway. The TWRP backup still works for other partitions, so an OS backup can be done, but you would have to backup your data and Apps with other means.

Be aware that TWRP never backs up the Internal Storage, so you would have to deal with Internal Storage differently anyway.

2 Likes

AFWAll+ is definetely not working with LOS17.1. Everything works fine without it, but once I only install it the mobile data reconnection problem appears and till now I can only fix it by deleting cache and any other data of AFWall+ and then uninstalling it. Only uninstalling didn’t work for me. Has anyone been able to run the firewall on LOS17.1 yet?

Hey there. I did a quick search but couldn’t find the answer…

I’m considering switching from FP2 stock OS to LOS 17.1 with the gapps. One thing I am wondering, is the battery life better comparing the FP2 stock OS with the LOS?

Which commits do you refer to? Please link them :slight_smile:
Chris

PS: Careful. The change log here does not mention lineage version:
https://download.lineageos.org/

So the two changes you might mean:

were not in 17.1 but in 16.0. The same changes on 17.1 are not yet merged.

1 Like

Maybe I mean these changes. Read about it somehow via the changes on the fp2.

I perceive that LOS with gapps (micro) is much better than FP2 OS…

1 Like

Hey! Today I tried switcing on the mobile data connection while the phone was in the power saving mode (battery under 10% in my case) and it didn’t connect… Is that a bug?

Thanks :slight_smile: I’ll make a backup tonight of the phone and go try it out then.

Sorry, can’t say.
and-this-to-fill-up-20-characters…

And without gapps but with F-Droid it is still better. :grin:

1 Like

I agree yeah haha. Though I need some gapps due to my university so that’s a bummer.

As for switching from stock OS to LOS; it went perfectly fine. I only restored a backup from WhatsApp and reinstalling everything I’ve used now without any issues. Only thing I noticed is that the launcher which I am using (Niagara Launcher) is lagging when the status bar is shown, I guess due to drop shadow effect? Notified the developer of the app anyway :slight_smile:

One more happy upgrader from LOS 16 to 17. I postponed it for months. I like the new background, the very slick setup and this page was the most useful, though it was a bit hidden. With it, i was able to get past the ‘no permissions (user in plugdev group;…’ error message.


I am looking forward to see if this avoids that random restart that put me off for a long time. If it still appears, then i will try without gapps.

2 Likes

I could implement a workaround for my WiFi troubles: I installed an additional repeater which is connected over a powerline adapter to the FRITZ!Box.

I think the WiFi troubles were caused by a weak signal in the 5 GHz network in combination with a missing fallback to the 2,4 GHz network. The FRITZ!Box is configured to use both frequency bands. Manually using the 2,4 GHz led to a stable but slow connection, so the workaround with the repeater also increases the network speed.

The troubles did not occur on lineage 16, so something relevant changed also on the lineage side.

I had my first reboot in LOS 17 yesterday. I had this problem with an older version of LOS aswell:

  • FP2 connected to VW car via bluetooth
  • GPS on
  • Google maps open with GPS active (but no navigation, just position on route).

After about 20 Mins, the FP2 just rebooted. Does anybody have this aswell? In the past it also happened when using OSMand.