Lineage 17.1 - FP2

Mobile Data is back to my phone. I am not quite sure which of the following steps was the important one that made everything work again but I will list what I did. Hopefully it will help…

  • I am using AFWall+. There I made sure, that [1073] NetworkStack, has acces to the internet.
  • I deletet my APN and created a new one. (For most german providers the only things to set are an random name and the APN internet)
  • I shut down my phone and rebooted it -> still no reconnection
  • I deactivated AFWall+ completely an rebooted again
  • I left the phone for about 10 minutes and after turning on AFWAll+ again the mobile data worked perfectly. I can now turn it on and off, switch to flight mode and reboot the phone without problems.

I have pretty much no idea, why these steps worked but well… It’s sometimes a bit of magic :slight_smile:

1 Like

Maybe this is related:"p-airplane-toggle-fix"+(status:open%20OR%20status:merged)


Huge drawback for fans of TWRP backup/restore (like me) - possibly due to the new “system-as-root” layout: They still seem to work (no errors or warnings) but a restored LOS 17.1 never boots again (endless boot logo).

Toggle Switch location missing since yesterday.
why can you no longer switch modes between precise and economical?


The switch was removed, because it was not working.

1 Like

That is no 17.1 thing, I experienced this with earlier versions, too.
Earlier versions would boot again if you just installed the LineageOS build corresponding to the restored OS again over the restored OS.
Somebody else even got it working again with installing a different build of the same general version over the restored OS.

Did you try this?

1 Like

Thanks for the hint, but I’m afraid this is not related.
The bugs relate to toggling airplane mode (i.e. all connections)
Whereas, at least in my case, it’s only reconnecting mobile data.
Toggling airplane mode has no influence on the faulty reconnect behavior.

I never experienced this and used TWRP for complete LOS restore from scratch quite often.

Thanks for the hint - I’ll try it and report here.

Didn’t work for me.
I deleted all old APNs & re-created a new one with basic settings of my provider.
But the problem remains.

Anyone else with experiences with deleting old APNs and recreating them?

I was probably just lucky. :frowning: Did you try to reboot after changing the settings? It worked only after reboot for me.

Yes, I did reboot.
Desperate guess: order of deleting & creating APNs
Did you first delete all old APNs and then create the new one?
Or other way round - create a new, test it and then delete the old?

In today’s update was something that could be the solution to you flight mode problem. could you try it?

Thanks for the hint, I will.
But actually it seems to be not related to flight mode but only to reconnect to mobile data.
All other reconnects (Wifi, 3/4G, Toggle flight mode, …) work fine.

1 Like

Since the first start of the update to 17.1-20200422 mobile data works fine here, even when I toggle mobile data or flight mode.


Needed an extra Reboot after the Update, but Problem solved.
Thanks to you all for your feedbacks.

1 Like

Restoring a TWRP backup of LOS 17.1 followed by an immediate installation of the same or newer LOS version leads to a working setup. Thanks again for the hint.


I recently installed Lineage OS nightly 17.1 in my FP2 but I get two bugs:

-After turning the phone on, I put the mobile data connection and it works… Only once, then when I want to reconnect it does not work until I restart the phone…

-The battery management is not very good, after having 50% (for instance) it can go to 2% in a minute (and set the dark mode) and afterwards to 46%… I don’t understand what is wrong.

Well, I hope the bugs can be fixed.

Thanks a lot, the OS is amazing otherwise!


The issue with mobile data reconnect should be fixed with 20200422 update - see above


yes. Data reconnection problem solved in my case! Thanks a lot.

Nevertheless, the battery issue is still there… Could it be something in my hardware only?

Also there is something else which might be of your interest: when I start the phone, there is this message “No SD card inserted” for 10 min or so, then it dissapear. No further problems.

Thanks again!

I have other question: I don’t find the tool “Checkup” for hardware diagnosis that the OS of FP2 used to have… Will it be available?