Lineage 17.1 - FP2

This is how I am able to access it:

  • Select Storage Access Framework on the home screen of Ghost Commander
  • When you are asked to allow access (this will only be asked once):
    • Select the storage you want to access (internal or external) if it isn’t already selected
    • Allow access
3 Likes

The AOSP calendar has been stripped down to some sort of “viewer”. :frowning:
See e.g.: https://android.googlesource.com/platform/packages/apps/Calendar.git/+/551499ec6d3878cd3dce99bebe08c4552d05c29c

Chris
While you get upset you could star this issue: https://issuetracker.google.com/issues/150765175

3 Likes

Thank you, so I need to lookup an alternative app for such a basic functionality… congrats Google :-1:!

Thanks :slight_smile:

If I want to update from FP Open - just delete and flash or do I have to install recovery first?

1 Like

I don’t think that the recovery of the latest FPOOS is able to flash the system. You’ll need to flash TRWP or LOS recovery first.

1 Like

Just to confirm that the updater indeed was fixed in 20200404: update to 20200405 went smoothly (I have TWRP 3.2.3).

7 Likes

I’ll try these and report back, which one I like more ;). But I still think that is makes no sense to discontinue a working calender app integrated in the base OS…

Of course that makes sense. Who does the heavy lifting to give you AOSP, and who wants you to better not use it as it is but go for their set of “improved” Apps instead :wink: ?

2 Likes

Does anybody know hot to get the automatic daylight depending switch from light to dark theme to work?
I found this article on XDA, which says, that the automatic switch is deactivated on Android 10 and it recommends a small app for that feature.
So is it the same an LOS 17.1?
I understand the settings that way, that a daytime depending switch is possible.

Go to Settings > Display > Dark theme > Schedule and select “Turns on from sunset to sunrise”:

Thanks for your reply :slight_smile:
Yes, thats what i have done but the theme didn’t switch at the sunset. Then i switched it manually on and it showed the message, that it will turned off at sunrise.
Naturally I turned on the schedule.

So for you it works?

I waited until 08:30AM but nothing happend and switched it manuallay again.
I had a similar situation with LOS16.
The switch between themes wasn’t at the correct time until I used GPS and the phone got the correct GEO dates of the phone to calculate the sunrise/sunset. From this point on the theme switch was correct.
But yesterday I already used the gps and it seems that it didn’t take any effect.

I dont want to be missunderstood. If its a bug, i’m totally fine with it and don’t want to appear unpatient or so. I can switch it manuallay until it works.
But if its a user mistake of me and it works in general, it would be nice to know :laughing:

1 Like

Not sure if it applies here but I’m a big user of the SMS app and noticed some problems:

  • The quick reply option in the status bar is now opening the app instead of allowing a reply to be typed directly in the status bar control
  • In that case (app opened from the “Reply” option in the status bar), the SMS still shows as “unread” in the conversations list

A missing feature: no quick app buttons on the lock screen bottom corners.

Also, the notification sound is heard if any notification in the list has a sound attached to it, as if the whole list is “replayed” whenever a new notification is added, even a silent one.
Example: I receive an SMS - notification sound is heard. I receive an email, for which notifications are silent (i.e. only displayed but no sound or vibration) - the SMS notification sound is played again.

Not sure if it’s linked to the FP2 or Lineage in general, but I thought I might share it, just in case…

Turning dark mode on / off at sunset / sunrise works for me with Lineage 17.1 and UnifiedNLP (location is set to battery saving mode). Are you sure there was a location available to calculate the sunrise / sunset times?

Alright.
Thank you.
I switched it again manually now and reconfigured the settings with GPS only (without WiFi & Mobile Network) and tried to controll it.
And the UI accessed the GPS as you can see here:

My installation worked fine, but mobile data is not working. I switched my firewall off, but still no difference.
Any ideas what I can try?

You should check APN settings. My one were wrong, too.

Chris

2 Likes

My installation (new install, after use LOS16) was very good. Only forgot to backup Whatsapp… (I don’t use Google anymore).

Now my rotation (screen), pedometer en acceleration sensors are working now on.
I had also my mobile data not working, but after a reboot, it came back.

For the next time, a better manual to upgrade should be fine.

Happy user of Lineage OS 17.1, good work developers!

3 Likes

Just wanted to tell everybody that my update went smoothly! :slight_smile: I am very happy with Lineage 17.1 now. Thank you so much @chrmhoffmann!

7 Likes