Lineage 17.1 for FP2 - Second preview version

Ah, well, so there’s ONE SINGLE study now and all previous studies (e.g. https://justgetflux.com/research.html) are void and let’s call it “Homeopathy”?!?

2 Likes

Thats what I’m saying. Don’t rate down the placebo effect. :wink:

All working fine. Thank you for your hard work :slight_smile:.

I tried an upgrade from 16.0 to 17.0 with an encrypted partition. When I rebooted, it told me that my encryption password was correct, but the data partition was corrupted. I reinstalled 16.0 and the phone booted again, but apps kept stopping. So, I decided to wipe the encrypted data partition (Fortunately, I backed everything up) and installed 17.0 and now I am very happy :slight_smile:.

Only thing I can’t get to work is encrypting my new data partition. Instead of rebooting and encrypting, it just reboots (without showing the ‘FAIRPHONE’ fastboot screen). Any ideas what I might be doing wrong?

Thanks again.

1 Like

Unfortunately there is not. The proximity sensor can only be calibrated when you have a FPOS/FP OpenOS installed (Settings > Maintainance > Proximity Sensor).

1 Like

My FP2 with LineageOS 16.0 has the Fairphone Proximity Sensor Tool too.

2 Likes

Not true since at least November 2017 :wink: .

Ah cool, sorry to interrupt then. :grin:

1 Like

If someone is really interested in understanding what Ingo said, there’s this freakin’ good, scientific article about science, media, fears and fallacies for regular hoomans (get away mice, over-pressured journalists, ultracrepidarian uncles and other trolls). Unfortunatelly, it’s written in Spanish. But, fortunatelly, we now have awesome contextual translators, :wink:.

1 Like

This works surprisingly well.

In addition to that you can also use the LiveDisplay > Color Calibration to reduce the brightness beyond the minimum brightness value. I use this feature a lot on Lineage 16 because otherwise the display would be too bright in dark environments.

For example today due to the rainy weather I set it to 80% during the day:

Screenshot_20191223-200413_LineageOS_Settings_kl

4 Likes

First results after testing the version for around 20 days:

  1. It was pretty stable during the first days. Currently the version crashes once a day. This might however be a problem of my phone which seems to have one of the unstable AA processors. I throttled it today with Kernel adiutor a bit. Let’s see if this solved the case.
  2. After some days I got some strange android app icons in the menu. When clicking on them the system tells me that a “webbrowser is needed” to access the content. After that an empty black Play Store window remains open in the background. I noticed that the first icon showed up after a crash. Sometimes the icons disappear again, however so far 3 of them seem to stay permanently. Will check if there is some pattern with that.
  3. After a restart after a crash with the internet turned off the phone jumped back from the 20th december to the 12th december 2019. Why it jumped back exactly these number of days is a bit unclear (maybe the 12th was the day I reinstalled the system and thus it goes always back to that date? Will check next time this happens). I don’t remember this time-set-backs after crashes in the regular FP OS.
2 Likes
  1. I could agree that it crashed very often - independent from active mobildata
  2. i do not know if it is a playstore issues, it is not possbile to install with f-droid apps on background/automatic

I’ve been using this (not as daily driver, though) since almost a month and noticed only two problems so far

  1. The setting to show battery percentage in the status bar is ignored (see this post + the one above)
  2. Wireless Display (see this post; notification LED problem mentioned there probably was a misconception)

What I didn’t test was upgrading from 16 to 17, it was a clean install with storage wipe.

Now that Android 10 might soon come to the FP2, maybe it’s an idea to try out this backup solution that is intended to replace the Google backup functionality (as it targets Android 10)

2 Likes

I have been using LOS 17.0 Beta0 for almost a month now (without GAPPS) as my daily driver and my experience was very positiv. I had a few random reboots though (1-2 per week).

This seemed to be an issue with the /system partition in Android 10 and is being worked on. You can use my hacked UnifiedNlp (only for LOS 17.0!) if you want to try it out.

But now that UnifiedNlp is installed I realized, that the Battery Saving option of Location does not work as expected. The GPS always used for location, not only Cell Towers and Wifi.

I still cannot make Live display work. @Ingo Did you setup anything different on your phone?
My live display looks like this:

1 Like

I didn’t do anything with the LiveDisplay settings, other than changing them to see if they have any effect and back again.
If I don’t forget I can later upload a screenshot of the settings, I don’t have the phone with me that runs 17.0

Daily usage update. It’s been fairly stable for me (uptime 409 h). Did a fresh install as I couldn’t upgrade from 16 to 17 with encrypted data partition.

I think I have some LOS app specific issues: Gallery (doesn’t seem to interact well with other apps, eg. photo sharing), Phone (won’t let me pick up incoming calls), Calendar (won’t show my Google calendars). but I’m guessing that’s due to them not being ready yet :slight_smile:.

Thanks for all your efforts getting this working. I’ve been enjoying showing people shiny new Android on relatively old phone :slight_smile:.

1 Like

If I didn’t miss something, it seems that livedisplay is not included in FP2 device tree.
something like this is needed to get it work:
https://review.lineageos.org/c/LineageOS/android_device_sony_msm8974-common/+/266370

2 Likes

Strange, LiveDisplay no longer works. If I change to something other than “off” it is ignored as soon as the selection pop up closes (opening the pop up still shows the ignored selection; it’s back to “off” once I leave the LiveDisplay settings).

Seems like this logcat entry is related:
01-06 19:41:51.381 E/InputDispatcher(1458): Window handle Window{1496e92 u0 org.lineageos.lineageparts/org.lineageos.lineageparts.livedisplay.LiveDisplaySettings} has no registered input channel

1 Like

Ciao!
I did a new test of LOS 17 today, and here is my findings:

  • “Split screen with multi-resume” is working :white_check_mark: (see my other post)
  • Magisk is giving me root access :white_check_mark: (successfully tested with Titanium Backup)
  • this root access can be hidden to certain apps :white_check_mark: (successfully tested with Pokémon Go)
  • my banking app however is not working :red_circle:, it detects that the device is rooted :frowning: even if I selected it inside “Magisk Hide”…
    Seems that my bank is getting really inventive with root detection, last version is detecting root also in my “LOS 16 + iSu” configuration, while previous version was working with it.
  • after restoring a TWRP backup, reboot is stuck :red_circle:, as already mentioned by @urs_lesse
    I let it doing its animation for more that 15min but nothing…

However, if I do (1) TWRP restore + (2) Flashing LOS17 zip without wiping data, then the system is starting correctly :white_check_mark:, with all the apps/settings/… and without the “Finalizing configuration” message I had after the upgrade.

I searched the web for incompatibilities between TWRP and LOS17 but didn’t find any recent post, so I assume this bug is FP2-specific…
@z3ntu what could we do to debug this? Is there any logs usefuls?

What do you mean by “repatch the boot image”? My Magisk installation was two really easy steps: flashing Magisk-v20.2.zip in TWRP, then install the MagiskManager-v7.5.0.apk as a regular app…

I confirm that with the File-App, apk installation is possible, thank you for pointing that out :smiley:

6 Likes

Even Magisk is conserved thanks to its survival script :smiley:

At some point earlier I ended up in a boot loop by just flashing Magisk directly. Since then, I always patch the original boot image (using the option in the Magisk Manager) and flash that. Maybe it’s not necessary anymore…

1 Like