English

Lineage-16.0 (Android Pie) Nightly

Thank you @ChuckMorris!

Great to know! Unfortunately I can’t remember if I encrypted my Fairphone 2 in LineageOS 14.1 or 15.1!! Is there a way to find out???

Also good to know. I will stay on TWRP 3.2.x for now, then!

1 Like

Check if you can access the data partition in TWRP. This only works if you encrypted in 14.1.

3 Likes

I wiped all and installed 16.0 with TWRP, encrypted data again, installed necessary apps and put my data back again, and everything works VERY fine. Even the search in settings works contrary to 15.1. And I’ve got the feeling that my battery charges better and works longer.

2 Likes

So I like LOS 16.0 very much but the following two privacy setting should be set as standard but aren’t currently set:

  1. Pull-Down-Menu: Location/Device only (instead of High accuracy)
  2. Calls-App: Settings/Phone number lookup: all disabled (instead of lookups enabled)
1 Like

But does encryption work reliably from scratch with LineageOS 16 (independent of TWRP)?

This way doesn’t seem to work anymore to remove and re-encryption. Are there new ways?

For me, yes.

Whenever I had trouble with encryption or wanted to make sure I wouldn’t get any in the first place, I did the following …

1 Like

Uh oh, looks like the TWRP 3.2.3 I have installed can see /data and its contents from the TWRP file manager. I was also able to use the “Mount” option in the TWRP main menu to unmount and re-mount the “Data” partition in Internal Storage. This means I must have encrypted my phone in LineageOS 14.1, right?

If so, and just to confirm, if I want to upgrade to LineageOS 16.x, I have to completely wipe my phone (but presumably not my micro SD card, right?) and install 16.0 from scratch? If so, exactly what should I wipe from within TWRP? After selecting “Wipe” from the TWRP main menu, I see that the default option is to wipe “Data, Cache, and Dalvik”. Is that enough, or should I do an “Advanced Wipe”, if so what partitions should I wipe???

Thank you @ChuckMorris !!

P.S. If I wipe, I’ll remember to back up settings and files stored in the phone’s internal storage.

Also, in reference to this post above by @AnotherElk :

Is the encrypted partition always /dev/block/mmcblk0p20? Or is there a way to find out?

1 Like

Not across different devices, but on all Fairphone 2s the partition layout should be the same.

This is an excellent point you are making, so to be safe here’s a source for this dd command including how to find out the exact path …

https://android.stackexchange.com/questions/98228/removing-encryption-from-recovery

"Destroy the LUKS Header for Filesystem Encryption

1. You need a recovery which will allow you to drop to a shell as root , so TWRP works in my case.

2. Locate the userdata partition by looking around in
/dev/block/platform/*/by-name/userdata .

3. Write out a ton of zeroes to the beginning of that partition to wipe the LUKS header:
dd if=/dev/zero of=$PATH_TO_YOUR_USERDATA bs=4096 count=512

I claim no responsibility for what you do with this command. If you screw this up, you can brick your phone by overwriting your bootloader or other critical partitions. Make sure that $PATH_TO_YOUR_USERDATA points to the real userdata partition. Check the size of that partition to make sure you’re wiping the right thing. I have a 16GB phone and userdata is 10.4GB, with the rest being dedicated to system , but your phone will be different.

4. Reformat that partition as ext4 using make_ext4fs $PATH_TO_YOUR_USERDATA . There might be errors, but usually they relate to not being able to find the internal “sdcard,” this is okay."

Hints:
The “looking around” in point 2 amounts to the “ls -l” command.
Reformatting the partition as in point 4 can comfortably done in TWRP with Wipe - Format Data, as already pointed out in my earlier post.

1 Like

Right.

Right. And not just “wipe”, but format the data partition. A “wipe” will just delete the files.

Right, if it is formatted as portable storage.

This is explained pretty well in the official install guide.

The procedure @AnotherElk explains (overwriting the first 2 MB of the data partition with zeros) is not always necessary. I switched from official Fairphone OS (Android 7) to LineageOS 16 and the standard procedure from the install guide was sufficient. Phone was encrypted in Fairphone OS. Not sure why this special treatment seems to be required sometimes.

2 Likes

I had to reinstall from scratch, due to some glitch, and restored via TiBu backup. System settings were included in the backup. Now, when i switch network allowance in the app info, the setting app crashes, and the the updated network allowance is only activated after a reboot. Anyone else, or do I have to start from scratch and not restore settings?

Edit: this seems only to happen when apps are blocked in the beginning. If net access is allowed, i can toggle it without settings crashing, and change is immediate

Edit2: I got a logcat:

07-27 21:23:02.783 11571 11571 E AndroidRuntime: FATAL EXCEPTION: main
07-27 21:23:02.783 11571 11571 E AndroidRuntime: Process: com.android.settings, PID: 11571
07-27 21:23:02.783 11571 11571 E AndroidRuntime: java.lang.IllegalStateException: command '2410 bandwidth addrestrictappsonwlan wlan0 10191' failed with '400 2410 Bandwidth command failed'
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.os.Parcel.createException(Parcel.java:1958)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.os.Parcel.readException(Parcel.java:1918)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.os.Parcel.readException(Parcel.java:1868)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.net.INetworkPolicyManager$Stub$Proxy.addUidPolicy(INetworkPolicyManager.java:352)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.net.NetworkPolicyManager.addUidPolicy(NetworkPolicyManager.java:168)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at com.android.settings.datausage.AppDataUsage.setAppRestriction(AppDataUsage.java:414)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at com.android.settings.datausage.AppDataUsage.setAppRestrictWlan(AppDataUsage.java:408)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at com.android.settings.datausage.AppDataUsage.onPreferenceChange(AppDataUsage.java:277)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.support.v7.preference.Preference.callChangeListener(Preference.java:1060)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.support.v7.preference.TwoStatePreference.onClick(TwoStatePreference.java:67)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.support.v7.preference.Preference.performClick(Preference.java:1122)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at com.android.settingslib.RestrictedSwitchPreference.performClick(RestrictedSwitchPreference.java:138)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.support.v7.preference.Preference.performClick(Preference.java:1107)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.support.v14.preference.SwitchPreference.performClick(SwitchPreference.java:210)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.support.v7.preference.Preference$1.onClick(Preference.java:172)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.view.View.performClick(View.java:6597)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.view.View.performClickInternal(View.java:6574)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.view.View.access$3100(View.java:778)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.view.View$PerformClick.run(View.java:25906)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.os.Handler.handleCallback(Handler.java:873)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.os.Handler.dispatchMessage(Handler.java:99)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.os.Looper.loop(Looper.java:193)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at android.app.ActivityThread.main(ActivityThread.java:6718)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at java.lang.reflect.Method.invoke(Native Method)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:493)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:858)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: Caused by: android.os.RemoteException: Remote stack trace:
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at com.android.server.NetworkManagementService.restrictAppOnWlan(NetworkManagementService.java:1914)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at com.android.server.net.NetworkPolicyManagerService.updateRulesForDataUsageRestrictionsULInner(NetworkPolicyManagerService.java:4000)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at com.android.server.net.NetworkPolicyManagerService.updateRulesForDataUsageRestrictionsUL(NetworkPolicyManagerService.java:3975)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at com.android.server.net.NetworkPolicyManagerService.setUidPolicyUncheckedUL(NetworkPolicyManagerService.java:2565)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 	at com.android.server.net.NetworkPolicyManagerService.setUidPolicyUncheckedUL(NetworkPolicyManagerService.java:2527)
07-27 21:23:02.783 11571 11571 E AndroidRuntime: 
07-27 21:23:02.826  1107  5731 W ActivityManager:   Force finishing activity com.android.settings/.SubSettings
07-27 21:23:02.835 11571 11571 I Process : Sending signal. PID: 11571 SIG: 9

And this worked before? Multicast is disabled for some reason on the kernel - I think since day one.

Chris

There are some new sim lock fixes coming in next nightly. I think some people here complained about dual SIM / lock issues.
https://review.lineageos.org/q/topic:"master-fixes"+(status:open%20OR%20status:merged)

Chris

5 Likes

Any update on this? Still waiting for my LOS16 upgrade until the Wifi issues are fixed :slight_smile:

I have the latest modem firmware, Ubiquiti AP, I run LOS 16 (microG version) and I cannot confirm your issue. You can disable multicasting and IGMP on your APs as well. Maybe I did this, not sure.

AVM Fritz!Box 6490 Cable (Fritz!OS 7.00) and 7590 (Fritz!OS 7.01) on my end with 2.4 and 5 Ghz activated … no WiFi issues for me, and yes, by checking this I just saw there are further Fritz!OS updates available.
Are you on Fritz!OS 7.xx already?

Something of interest in the router’s event log perhaps (System - Ereignisse)?

At home I see quite some automatic channel switches because the router at home detected “a very strong jamming source” or “priviledged user (e.g. RADAR)” on the channels it wanted to use for WiFi … but that doesn’t translate into issues for me, just saying that the event log could be an interesting read.

1 Like

First of all, thanks for @ChuckMorris and @AnotherElk for their help, I was able to wipe and install the latest LineageOS 16.0 (build 29 July 2019) and restored my apps.

However, there is a major problem: My wifi and mobile data connections have become absolutely atrocious.

For wifi, my home, work, and other public connections that didn’t have any problems when I was on Lineage OS 15.1 have become almost unusable. My Fairphone 2 would claim that there is a strong connection, but my communications apps would say the server connection has been lost, and my web browsers (such as Firefox for Android) would give non-stop “server not found” errors. Other apps also appear offline.

If I try all of the above for an hour, including cold-booting my phone, the wifi connection might suddenly work for a couple of minutes but stop working completely again. This includes 2.4 and 5 GHz connections in uncrowded environments, and no other devices have problems.

For my mobile data connection (I’ve tried 4G/LTSE, 3G, and less), I get practically zero connection, which would suddenly work for literally just a few random minutes per day. All apps claim that I don’t have an Internet connection. This is despite getting “full bars” indicating a strong data signal from my mobile service.

In both cases, I made sure the firewall is completely turned off to no effect. Turning off the phone completely and rebooting didn’t help much, either.

This is making my phone practically useless apart from making old-school phone calls (which still works).

I also see sporadic reports of bad wifi in this thread, but not sure if they are related.

Anyway, are these known issues? How do I fix them? Or should I downgrade to 15.1 for now??? Thank you.

This for me is the thing that doesn’t quite fit in the picture.
Do you get any indication of G or E or H or LTE with the full bars?

If not, perhaps the full bars icon is wrong and you should have a look at the antenna connection and the contacts …

I remember back with LineageOS 14.1 on rare occasions I lost all mobile network connection by simply leaving the range of my home WiFi … and the status icon would show me full bars without any indication of G or E or H or LTE, which should mean a mobile network connection with plain 2G data speed, but there was no connection at all.
Turning flight mode on and off or a reboot fixed these, and this didn’t happen for a long time now, so probably your case is different, but you never know …

3 Likes

Today I’ve done a complete re-install with LOS 16 (came from 15.1 encrypted with 14.1) and haven’t had any problems so far. Time will tell if the occasional reboots persist.

I already love LOS 16 for having built-in DNS-over-TLS support which saves me from running Nebulo etc. in the background. Apart from that it seems pretty un-changy.

Big thanks to @chrmhoffmann! :love_letter: :wink:

3 Likes

Thank you @AnotherElk and everyone.

I have done further testing over the past few days, and I can confirm that not only do my mobile signal show full bars, LTE also shows up under the icon like this:

I tried the trick of turning airplane mode on and off to “reset”, and it seems that the mobile data connection would work very briefly because I would suddenly get a series of incoming messages (from IM apps) that I missed. However, after about 3-5 seconds, even though the icon still says LTE, all Internet connectivity would be lost again.

In addition, even though I would receive a few messages just as I turn airplane mode off, my web browser wouldn’t be able to open any webpage even during those 3-5 seconds either with timeout or not found errors.

To reiterate, my Fairphone 2’s mobile data connection (which is 4G/LTE) worked perfectly fine until I wiped LineageOS 15.1 and installed 16.0. The main symptom is that while it would show full bars with LTE underneath the mobile data icon, my phone has no Internet connectivity unless connected to Wi-Fi. I do not have any firewalls or VPNs active on this phone.

Can anyone provide further advice or suggestions?

And would it help if I created a new thread for this?

Thank you!