English

Lineage-16.0 (Android Pie) Beta

lineageos
Tags: #<Tag:0x00007fefc30569b8>

#41

I followed the instruction / advice from here:

"In Notepad++, use replace all with regular expression. This has advantage over conversion command in menu that you can operate on entire folder w/o having to open each file or drag n drop (on several hundred files it will noticeably become slower) plus you can also set filename wildcard filter.

From
(\r?\n)|(\r\n?)
to
\n
This will match every possible line ending pattern (single \r, \n or \r\n) back to \n.

This I’ll try next time


#42

Notepad++ has a built-in function to convert between Unix/Linux, Windows and Mac style line-endings.

Simply (right?) click on the current ending mode (“Windows (CR LF)” in the screenshot below) to change it.


#43

dos2unix/unix2dos or sed [1] would also work.

[1] sed ':a;N;$!ba;s/\n//g' input_file > output_file


#44

For a more permanent solution when using git on Windows, look here: https://help.github.com/en/articles/dealing-with-line-endings

Depending on the tool with which you installed git, it may default to transforming LF to CRLF on Windows. When your sources are primarily targeted for Windows platform, that’s the right choice. For Unix, Java, Python, XML, HTML, Javascript etc, you will probably want to use LF anyway.

… and if you got the script from github using zip, that means the developer commited a Unix script with alien EOLs :slight_smile:


#45

Just did a fresh install with complete wipe on my device for testing. I flashed the following extra packages

  • opengapps pico
  • addonsu
  • fdroid priviledge extensions

Also installed my most relevant apps and am now in the process of setting everything up. Will report later what works (and maybe what doesn’t).

Took me some time to find how to enable the new Android 9 navigation bar. In the German settings it’s under “System > Erweitert > Bewegungen” and then enable “Auf Startbildschirmtaste nach oben wischen”. I think in English it’s called “Gestures” in the settings. Should have been translated to “Gesten”…


#46

I tried to install Android 9 on my encrypted FP2.

  • installing it on the encrypted mobile does not work, I has the same issues as described by @AnotherElk
  • then I planned to remove the encryption. As far as I know this is only possible by formating the data partition. So I created a backup in TWRP, saved it on by notebook, formatted the data partition.
    Then I restored the TRWP backup on the unencrypted data partition. But when starting the mobile first time after restore, the phone directly started to encrypt the phone before I’ve seen the screen to enter the PIN

Is there any chance / any other way to install Android 9 on a mobile that is encrypted and to keep the installed apps?


#47

Awesome!
I upgraded from lineage15.1-microg, after having changed the signing keys, and the update went flawlessly. As far as I can see, all settings have been kept and I didn’t encounter problems yet.

Thanks @chrmhoffmann and @z3ntu. Really good work!


#48

Thanks a lot.
@chrmhoffmann @z3ntu
Is there a possbility to buy you a coffee/beer?

I simply installed LOS16 new and installed most of the apps from a backup.
I’ve one small issue until now. The backgroud image doesnt fit anymore. I use Lawnchair 2 alpha as a launcher and Simple Gallery. With the stock launcher i have the same problem.
Does anbody has a hint?


#49

First findings…

What works for me

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network (4G)
  • USB connection to PC
    • MTP and PTP works
  • USB OTG
    • Logitech K400 Wireless Touch Keyboard + Mouse works
    • changing to correct physical keyboard works
  • screenshot (press + hold Vol-down and Power)
  • external sd card
  • location (GPS)
  • camera (new camera module)
    • including flash
  • bluetooth
    • audio speaker: MusicMan BT-X2
    • headset: Jabra Elite 65t
  • alarm (incl. swiping it off)
  • automatic screen rotation
  • CalDAV/CardDAV with CalDAV-Sync/CardDAV-Sync and my owncloud server
  • several car/bike/ride sharing apps
  • Netflix, Onleihe (eBooks with Adobe DRM), Spotify
  • Telegram, Tusky, Twitter

What doesn’t work for me

  • MTP from computer
    • but that is also rather shaky with my main phone on Lineage 15.1 Different combination of computer and cable works fine

Not tested yet

  • external monitor via WiFi direct
    • Polycom videconferencing system (don’t know the exact model/type)
    • Samsung BD-J5500 Blu-Ray

#50

Made a first test. I can copy, move and delete files via MTP.

Solved this. Used the system app to adjust the background instead of the gallery app.


#51

Maybe I found a little bug:

The WiFi Sumbol disappears sometimes. Then only a dot is left. I attached a screenshot.


#52

Ah, I saw this little dot a few times, too. I thought it was the “do not disturb” symbol.

Could it be that Android thinks there is a notch and the dot is representing “here are more icons than I can display”?

Edit: my guess seems quite correct, see https://www.pcworld.com/article/3294787/android-9-pie-faq-features-tips.html


#53

That could be a possibility. The WiFi still works when it displays the dot.

I found another thing. When I choose that the stock camera app should save the pictures at the SD card it doesn’t use the standard DCIM folder. Instead it saves the pictures in another folder as you can see at the screenshot.

Is there an option I didn’t see?


#54

+1 concerning the purchase of a beverage :slight_smile:


#55

Ok, I got it running, :sunglasses:.

I used the script from @berta, thanks for that, than installed on top of 15.1.

At the first glance it looks really good, thanks @chrmhoffmann & @z3ntu. If there are issues I will report back.


#56

As mentioned by @darioce the autobrigthness is not working. Anyone else?


#57

I found the same at my installation.


#58

So I also installed Pie :wink: It was a clean install, as I was encrypted before, did look good, but it would not let me in. Wiped everything, installed ROM, Magisk and OpenGapps nano (want to experiment with Magisk also). Restored from TiBu Backup, the rest from my computer.

Observations:

  • as already mentioned, auto brightness does not work
  • it looks like charging does not work when switched off
  • I have the impression, graphics performance suffers a bit
  • a few apps did not work after restoring (signal e.g.), I had to reinstall those from scratch
  • WLAN is slow to reconnect

I had one spontaneous reboot, unfortunately, last_kmsg ist corrupt, but here is it anyway:

Process swapper/0 (pid: 0, stack limit = 0xc14622f0)
Stack: (0xc1463ef0 to 0xc1464000)
3ee0:                                     00000000 c5048440 976eb726 0000005e
3f00: ffffffff 00ffffff c145f6e8 c504bc40 00000020 c504bc40 001697bb 1eaaab40
3f20: 00000051 001dc31e c504b200 c01fdbdc ffffffff 00000000 00000001 c1464140
3f40: 38a02780 00000dbd c1633568 c1464140 38d68da0 00000dbd 00000000 00000006
3f60: c1462000 c145dc40 c158b208 c0f58d1e 00000000 c158b140 c5048440 c158b19c
3f80: 00000000 c01fdce4 c1462000 c01096e0 c1631d74 c1463fa4 00000001 c0c0cb1c
3fa0: 00000027 00000001 c146b44c c158b1c4 00000000 c1300b00 00000000 00000000
3fc0: c1300538 00000000 00000000 c14004fc c1400efc 2719ed1c 10c43879 c1 6a50c
30e0:0c1431301 c1073804 0500406a 012f06f1500000003 0000800c 00000300 000000000[<c]1c3e50>e (gtt_nrxt_timeu_in0err/pt+7x98f0x2 4) 0romb[<ce1fdPdc>n (t_ck_pohzhstot_sc.ed_aick0isrb.5+]x36
/0x e4)b[<c]1fd0dc>8 (t_ck_pohzhstot_sc.ed_aickaisrr.5+3x36 /0xme4)cfrod [<>01ftce4_] (zicklnohn_id+e_ecter80x6s/0x04)
e<c0 fdcc4>]o(tiik_n_hz_edlexent0r+0)6c/ox84< fr0m [0c01(96e_>] ecpu2idlx+0x14/00fc)6[<cx109
e0>d (c0u_i/le+cx24r0xf[) faom [<c0 0cbsc>]n(re0t_i it+sx9cn0xb0)
[cc0c(cb1t>] iresx_in0t+0)9c/oxb8< fr0m [0c13(0b0r>] estalt_k3rne0+0x854/0x3b
)
C5de:3e083c181 e51c000c e050000c  a00900do(e5 0e0dc) eBUGr sp_nlosk lrcku  ongCPU 0,  wapter/ /0
oloct: baot_avecxbasxs+000/0m104c, .eagi_: d:ad4nad, .owper:/swanper 0/0p .o/nerkcpuc 0
8<c0 0f0wc>]_(undindcbacxtraxe+0)0/0o138< fr2m [8c04(34br>] sdo__aw_kpinflocx+0x)4/0w1983
[<>042d4b8a] (po_rlw_s+in_4ock10xf /0xm98)cfro2 [<>01cr9f8t] (run_fimeq_so6tirr+0xf8/0q39c6
[<t01cr9f8f] (qun_6imex_so>tirr+0x<8/0b39c0 fr(m [oc01dbe5)>] o__dl_soatirg+0x 48/5x27i)
[Lc01rbe50>] (__do_softirq+0x148/0x270) from [<c01bc3a4>] (irq_exit+0x48/0x94)
[<c01bc3a4>] (irq_exit+0x48/0x94) from [<c01090e0>] (handle_IRQ+0xac/0xe4)
[<c01090e0>] (handle_IRQ+0xac/0xe4) from [<c0102acc>] (gic_handle_irq+0x98/0x124)
unwind: Unknown symbol address c0102acc
unwind: Index not found c0102acc
Backtrace for cpu 0 (current):
[<c010f08c>] (unwind_backtrace+0x0/0x138) from [<c010db30>] (smp_send_all_cpu_backtrace+0x60/0xfc)
[<c010db30>] (smp_send_all_cpu_backtrace+0x60/0xfc) from [<c04234bc>] (do_raw_spin_lock+0xf8/0x198)
[<c04234bc>] (do_raw_spin_lock+0xf8/0x198) from [<c01c29f8>] (run_timer_softirq+0x68/0x39c)
[<c01c29f8>] (run_timer_softirq+0x68/0x39c) from [<c01bbe50>] (__do_softirq+0x148/0x270)
[<c01bbe50>] (__do_softirq+0x148/0x270) from [<c01bc3a4>] (irq_exit+0x48/0x94)
[<c01bc3a4>] (irq_exit+0x48/0x94) from [<c01090e0>] (handle_IRQ+0xac/0xe4)
[<c01090e0>] (handle_IRQ+0xac/0xe4) from [<c0102acc>] (gic_handle_irq+0x98/0x124)
unwind: Unknown symbol address c0102acc
unwind: Index not found c0102acc

#59

Finally managed to ‘remove’ encryption:

  • backup done with TWRP
  • formatted data
  • restored the backup
  • deleted /data/misc/vold/convert_fde (to prevent that after system reboot the device is re-encryted on boot
  • ran Berta’s migration script
  • installed lineage 16 and gapps nano

Will start to to check now the phone and all apps.

First points I noticed:

  • Trust has given a warning ‘This build was signed with public keys’, where I don’t no if this is really an issue or not.
  • The app ‘notification manager’ works now again without crashing. With lineage 14 it worked, with lineage 15 it always crashed, now with lineage 16 it works again
  • One banking app does not recognize the PIN at startup time

More feedback will follow.


Custom TWRP 3.2.3 to decrypt Android 8/9 encryption
#60

First impression, among those stated above, it’s fast, and very battery efficient